{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58390 exists.","fix":"No fix has been published for CVE-2026-58390 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-58390 is a high-severity cross-site scripting vulnerability in opnsense core, published on 15 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-58390 and fix it if it is affected.\n\nWhat it is: CVE-2026-58390 is a high-severity cross-site scripting vulnerability in opnsense core, published on 15 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58390 exists.\n\nAffected product: opnsense core. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-58390/ (Markdown: https://insights.sbomify.com/CVE-2026-58390/index.md)","id":"CVE-2026-58390","markdown":"https://insights.sbomify.com/CVE-2026-58390/index.md","name":"CVE-2026-58390","record":{"aliases":["GHSA-26cj-h9rj-g5pf"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"OPNsense firewall","requires_auth":"low_privilege","summary":"Stored XSS in OPNsense OpenVPN status views allows attackers to execute arbitrary code and gain root privileges if specific authentication configurations are used.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"OPNsense is a FreeBSD based firewall and routing platform. Prior to version 26.1.11, the OpenVPN connection-status dashboard widget in src/opnsense/www/js/widgets/OpenVPNClients.js and the connection-status view place a client common_name into data-common-name attributes without quote-safe encoding. Exploitation requires an OpenVPN server configured with username-as-common-name and RADIUS or LDAP authentication, plus the ability to provision or self-register a valid backend username containing a double quote; deployments where the same administrator controls both the identity backend and firewall do not cross a separate trust boundary. An authenticated client using that username can close the attribute and add an event handler, while the local user database is not affected because its username validator rejects quotes. Script executes in an administrator's session when the administrator opens the dashboard or connection-status page and the injected event is triggered; the demonstrated payload used pointer movement over the client row rather than unconditional page-load execution. The advisory demonstrates that the script can read config.xml, invoke privileged APIs, reset the root password, and obtain root command execution. This issue is fixed in version 26.1.11.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"OPNsense: Stored XSS to root RCE via OpenVPN client common_name in status views","id":"CVE-2026-58390","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"OPNsense: Stored XSS in Firewall Rules/NAT pages via a HTML-attribute breakout","id":"CVE-2026-58391"},"packages":[],"prev":{"headline":"Apache Thrift: Rust binary protocol non-strict path missing string size limit","id":"CVE-2026-58389"},"products":["core"],"published":"2026-10-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-20","vendors":["opnsense"]},"summary":"Stored XSS in OPNsense OpenVPN status views allows attackers to execute arbitrary code and gain root privileges if specific authentication configurations are used.","url":"https://insights.sbomify.com/CVE-2026-58390/"}