# CVE-2026-58393: OPNsense: OpenVPN Client Specific Override common_name allows path traversal in generated CSO files

> Authenticated users with CSO privileges can write OpenVPN config files outside intended directories via path traversal in common_name.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** GHSA-2m9v-p7r9-gfcw

## What is CVE-2026-58393?

CVE-2026-58393 is a medium-severity path traversal vulnerability in opnsense core, published on 15 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OPNsense is a FreeBSD based firewall and routing platform. Prior to version 26.1.11, the OpenVPN Client Specific Override common_name field accepts path traversal sequences and openvpn_csc_conf_write() concatenates the value into /var/etc/openvpn-csc/<vpnid>/<common_name> without normalization or a basename check. The affected event handlers are client_connect.php and user_pass_verify.php. An authenticated user with Client Specific Override privileges can store the traversal value, and a matching OpenVPN client-connect or authentication event causes a generated CSO file to be written outside the intended directory. The file content is generated OpenVPN configuration rather than arbitrary bytes, and practical exploitation requires the attacker to cause a matching common name or username to be processed. This issue is fixed in version 26.1.11.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-58393?


## How do I fix CVE-2026-58393?

No fix has been published for CVE-2026-58393 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-58393 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58393 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58393 and fix it if it is affected.

What it is: CVE-2026-58393 is a medium-severity path traversal vulnerability in opnsense core, published on 15 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58393 exists.

Affected product: opnsense core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58393/ (Markdown: https://insights.sbomify.com/CVE-2026-58393/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58393
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58393
- OSV: https://osv.dev/vulnerability/CVE-2026-58393

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58393/
Summaries are generated and may contain mistakes; the official description above is the record.
