{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58394 exists.","fix":"No fix has been published for CVE-2026-58394 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-58394 is a medium-severity cross-site scripting vulnerability in opnsense core, published on 15 Oct 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-58394 and fix it if it is affected.\n\nWhat it is: CVE-2026-58394 is a medium-severity cross-site scripting vulnerability in opnsense core, published on 15 Oct 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58394 exists.\n\nAffected product: opnsense core. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-58394/ (Markdown: https://insights.sbomify.com/CVE-2026-58394/index.md)","id":"CVE-2026-58394","markdown":"https://insights.sbomify.com/CVE-2026-58394/index.md","name":"CVE-2026-58394","record":{"aliases":["GHSA-8pgr-x852-qx4j"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"OPNsense firewall","requires_auth":"high_privilege","summary":"An attacker with certificate management privileges can inject malicious scripts into certificate descriptions, leading to code execution when administrators view settings.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"OPNsense is a FreeBSD based firewall and routing platform. Prior to version 26.1.11, src/www/system_advanced_admin.php reads certificate records into $a_cert but omits that array from legacy_html_escape_form_data() before rendering each certificate descr value in the SSL Certificate selector. The certificate description accepts HTML metacharacters, allowing a user with the page-system-certmanager privilege to store markup that executes when another user opens System Settings Administration. This issue is fixed in version 26.1.11.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"OPNsense: Stored XSS in Administration Settings via Certificate Description","id":"CVE-2026-58394","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"OPNsense: XPath injection in MVC safe-delete","id":"CVE-2026-58395"},"packages":[],"prev":{"headline":"OPNsense: OpenVPN Client Specific Override common_name allows path traversal in generated CSO files","id":"CVE-2026-58393"},"products":["core"],"published":"2026-10-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-15","vendors":["opnsense"]},"summary":"An attacker with certificate management privileges can inject malicious scripts into certificate descriptions, leading to code execution when administrators view settings.","url":"https://insights.sbomify.com/CVE-2026-58394/"}