# CVE-2026-58394: OPNsense: Stored XSS in Administration Settings via Certificate Description

> An attacker with certificate management privileges can inject malicious scripts into certificate descriptions, leading to code execution when administrators view settings.

- **Severity:** Medium 5.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** GHSA-8pgr-x852-qx4j

## What is CVE-2026-58394?

CVE-2026-58394 is a medium-severity cross-site scripting vulnerability in opnsense core, published on 15 Oct 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

OPNsense is a FreeBSD based firewall and routing platform. Prior to version 26.1.11, src/www/system_advanced_admin.php reads certificate records into $a_cert but omits that array from legacy_html_escape_form_data() before rendering each certificate descr value in the SSL Certificate selector. The certificate description accepts HTML metacharacters, allowing a user with the page-system-certmanager privilege to store markup that executes when another user opens System Settings Administration. This issue is fixed in version 26.1.11.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-58394?


## How do I fix CVE-2026-58394?

No fix has been published for CVE-2026-58394 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-58394 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58394 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58394 and fix it if it is affected.

What it is: CVE-2026-58394 is a medium-severity cross-site scripting vulnerability in opnsense core, published on 15 Oct 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58394 exists.

Affected product: opnsense core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58394/ (Markdown: https://insights.sbomify.com/CVE-2026-58394/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58394
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58394
- OSV: https://osv.dev/vulnerability/CVE-2026-58394

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58394/
Summaries are generated and may contain mistakes; the official description above is the record.
