# CVE-2026-58395: OPNsense: XPath injection in MVC safe-delete

> Attackers with module privileges can exploit XPath injection in safe-delete endpoints to read configuration data from unauthorized modules.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** GHSA-98h6-479q-9q3w

## What is CVE-2026-58395?

CVE-2026-58395 is a medium-severity vulnerability in opnsense core, published on 15 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OPNsense is a FreeBSD based firewall and routing platform. Prior to version 26.1.11, the safe-delete path reached through ApiMutableModelControllerBase::delBase() interpolates an unvalidated safe-delete token from the request URL into an XPath expression over config.xml before confirming that the token is a valid identifier. A user holding any one affected module privilege can send a crafted token to one of 21 affected delete endpoints covering Traffic Shaper, DHCP relay, Dnsmasq, Firewall Category, or Kea DHCP, causing the XPath to match configuration data across modules. The resulting error response exposes configuration item names, descriptions, reference paths, and UUIDs and provides an XPath substring-presence oracle, including for modules the user cannot otherwise access. The request does not modify configuration or perform a deletion. This issue is fixed in version 26.1.11.

Weakness: CWE-643 (Improper Neutralization of Data within XPath Expressions)

## Which versions are affected by CVE-2026-58395?


## How do I fix CVE-2026-58395?

No fix has been published for CVE-2026-58395 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-58395 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58395 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58395 and fix it if it is affected.

What it is: CVE-2026-58395 is a medium-severity vulnerability in opnsense core, published on 15 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58395 exists.

Affected product: opnsense core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58395/ (Markdown: https://insights.sbomify.com/CVE-2026-58395/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58395
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58395
- OSV: https://osv.dev/vulnerability/CVE-2026-58395

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58395/
Summaries are generated and may contain mistakes; the official description above is the record.
