# CVE-2026-58400: GeoNetwork vulnerable to Remote Code Execution via unsafe Saxon XSLT processor configuration in formatter

> Privileged users can achieve remote code execution by uploading malicious XSLT stylesheets due to unsafe Saxon processor configuration.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** GHSA-x898-729x-cc3r

## What is CVE-2026-58400?

CVE-2026-58400 is a critical code injection vulnerability in core-geonetwork, published on 3 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

GeoNetwork is a catalog application to manage spatially referenced resources. Prior to versions 4.4.12 and 4.2.17, the Saxon XSLT processor used to render formatters is configured without secure processing (`FEATURE_SECURE_PROCESSING`) and without disabling Java extension functions (`ALLOW_EXTERNAL_FUNCTIONS`). Any stylesheet loaded by GeoNetwork can therefore invoke
`java.lang.Runtime.exec()` or `java.lang.ProcessBuilder` directly, achieving arbitrary command execution as the GeoNetwork process user. A user with sufficient privileges to upload a formatter can deliver a `.xsl` file containing Java extension call that execute arbitrary OS commands with the privileges of the GeoNetwork process. The issue is patched in GeoNetwork versions 4.4.12 and 4.2.17.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2026-58400?


## How do I fix CVE-2026-58400?

No fix has been published for CVE-2026-58400 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-58400 being exploited?

There is no known exploitation of CVE-2026-58400 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58400 and fix it if it is affected.

What it is: CVE-2026-58400 is a critical code injection vulnerability in core-geonetwork, published on 3 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-58400 in the wild and no public exploit code.

Affected product: core-geonetwork. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58400/ (Markdown: https://insights.sbomify.com/CVE-2026-58400/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58400
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58400
- OSV: https://osv.dev/vulnerability/CVE-2026-58400

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58400/
Summaries are generated and may contain mistakes; the official description above is the record.
