# CVE-2026-58404: Hugo security.http.urls deny rules bypassed by alternate IPv4 encodings

> Attackers can bypass URL deny rules using alternate IPv4 encodings to access internal services or cloud metadata during Hugo builds.

- **Severity:** Medium 4.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 7 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-58404, GHSA-r46f-3rpw-hxrv, GO-2026-5606, UBUNTU-CVE-2026-58404

## What is CVE-2026-58404?

CVE-2026-58404 is a medium-severity server-side request forgery vulnerability in gohugoio hugo, published on 6 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Hugo is a static site generator. From v0.162.0 through v0.163.0, the default security.http.urls policy denies requests to loopback, internal, and cloud-metadata IPv4 literals, but the deny rule only matched dotted-decimal notation, so alternate IPv4 encodings of the same addresses, including integer, hex, or octal, passed the policy. When a template passes an untrusted or data-derived URL to resources.GetRemote and the host platform uses the cgo system resolver, these encodings resolve to the blocked address, allowing build-time server-side requests to loopback and internal services, including the cloud-metadata endpoint in hosted or CI builds; the same check is reused on redirects, so the gap also applies to each redirect hop. This issue is fixed in v0.163.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-58404?

3 open source packages ship an affected version, including github.com/gohugoio/hugo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gohugoio/hugo` | Go | From 0.162.0 | 0.163.1 |
| `github.com/gohugoio/hugo` | Go | From 0.162.0 | 0.163.1 |
| `github.com/gohugoio/hugo` | Go | From 0.162.0 | 0.163.1 |

Products: Gohugo Hugo.

## How do I fix CVE-2026-58404?

Upgrade github.com/gohugoio/hugo to 0.163.1 or later.

## Is CVE-2026-58404 being exploited?

There is no known exploitation of CVE-2026-58404 in the wild and no public exploit code.

## Other vulnerabilities in gohugoio hugo

- [CVE-2026-75926](https://insights.sbomify.com/CVE-2026-75926/): Hugo 0.162.0 to 0.164.x - Node Permission Model Bypass via Default TailwindCSS Child-Process Grant (critical 9.3)
- [CVE-2026-100690](https://insights.sbomify.com/CVE-2026-100690/): Hugo v0.161.0 to v0.165.0 Arbitrary File Read via Symlinks (high 8.7)
- [CVE-2026-100692](https://insights.sbomify.com/CVE-2026-100692/): Hugo before v0.166.0 Path Traversal via Symlinked Mount Roots (high 8.7)
- [CVE-2026-100693](https://insights.sbomify.com/CVE-2026-100693/): Hugo v0.162.0 before v0.166.0 IP-literal Deny Rule Bypass (high 8.6)
- [CVE-2020-26284](https://insights.sbomify.com/CVE-2020-26284/): Hugo can execute a binary from the current directory on Windows (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58404 and fix it if it is affected.

What it is: CVE-2026-58404 is a medium-severity server-side request forgery vulnerability in gohugoio hugo, published on 6 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-58404 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/gohugoio/hugo (Go): affected from 0.162.0; fixed in 0.163.1
- github.com/gohugoio/hugo (Go): affected from 0.162.0; fixed in 0.163.1
- github.com/gohugoio/hugo (Go): affected from 0.162.0; fixed in 0.163.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58404/ (Markdown: https://insights.sbomify.com/CVE-2026-58404/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58404
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58404
- OSV: https://osv.dev/vulnerability/CVE-2026-58404

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58404/
Summaries are generated and may contain mistakes; the official description above is the record.
