{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58409 exists.","fix":"No fix has been published for CVE-2026-58409 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-58409 is a critical vulnerability in ChurchCRM CRM, published on 13 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-58409 and fix it if it is affected.\n\nWhat it is: CVE-2026-58409 is a critical vulnerability in ChurchCRM CRM, published on 13 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58409 exists.\n\nAffected product: ChurchCRM CRM. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-58409/ (Markdown: https://insights.sbomify.com/CVE-2026-58409/index.md)","id":"CVE-2026-58409","markdown":"https://insights.sbomify.com/CVE-2026-58409/index.md","name":"CVE-2026-58409","record":{"aliases":["GHSA-37mf-vq43-5qp9"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"ChurchCRM","requires_auth":"high_privilege","summary":"An authenticated administrator can achieve remote code execution by uploading a malicious plugin ZIP containing a PHP webshell due to insufficient extension filtering.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"ChurchCRM is an open-source church management system. Prior to version 7.4.0, an authenticated administrator can achieve Remote Code Execution (RCE) on the server by installing a malicious plugin ZIP archive containing a PHP webshell. The application explicitly includes 'php' in its ALLOWED_EXTENSIONS list, while the dangerous extensions denylist (DENIED_EXTENSIONS) fails to block standard .php files. Because `php` is explicitly included in the allowed extension list for plugin archives, and extracted files are placed directly under the web root, any PHP file inside the ZIP becomes immediately executable via HTTP — without even needing to \"enable\" the plugin through the application UI. The /plugins/install-url API route (management.php) allows an administrator to source the malicious ZIP from any attacker-controlled HTTPS URL, validating it only against an attacker-supplied SHA-256 hash. This issue has been fixed in version 7.4.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"ChurchCRM: Authenticated Remote Code Execution (RCE) via Malicious Plugin Upload","id":"CVE-2026-58409","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"file_upload","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"ChurchCRM: Improper object-level authorization allows low-privileged users to read and modify other families’ records","id":"CVE-2026-58410"},"packages":[],"prev":{"headline":"ChurchCRM : Broken Access Control in `CSVCreateFile.php` Allows Low-Privileged Users to Export All Members' PII","id":"CVE-2026-58408"},"products":["CRM"],"published":"2026-07-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-14","vendors":["ChurchCRM"]},"summary":"An authenticated administrator can achieve remote code execution by uploading a malicious plugin ZIP containing a PHP webshell due to insufficient extension filtering.","url":"https://insights.sbomify.com/CVE-2026-58409/"}