# CVE-2026-58409: ChurchCRM: Authenticated Remote Code Execution (RCE) via Malicious Plugin Upload

> An authenticated administrator can achieve remote code execution by uploading a malicious plugin ZIP containing a PHP webshell due to insufficient extension filtering.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-37mf-vq43-5qp9

## What is CVE-2026-58409?

CVE-2026-58409 is a critical vulnerability in ChurchCRM CRM, published on 13 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

ChurchCRM is an open-source church management system. Prior to version 7.4.0, an authenticated administrator can achieve Remote Code Execution (RCE) on the server by installing a malicious plugin ZIP archive containing a PHP webshell. The application explicitly includes 'php' in its ALLOWED_EXTENSIONS list, while the dangerous extensions denylist (DENIED_EXTENSIONS) fails to block standard .php files. Because `php` is explicitly included in the allowed extension list for plugin archives, and extracted files are placed directly under the web root, any PHP file inside the ZIP becomes immediately executable via HTTP — without even needing to "enable" the plugin through the application UI. The /plugins/install-url API route (management.php) allows an administrator to source the malicious ZIP from any attacker-controlled HTTPS URL, validating it only against an attacker-supplied SHA-256 hash. This issue has been fixed in version 7.4.0.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-58409?


## How do I fix CVE-2026-58409?

No fix has been published for CVE-2026-58409 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-58409 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58409 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58409 and fix it if it is affected.

What it is: CVE-2026-58409 is a critical vulnerability in ChurchCRM CRM, published on 13 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58409 exists.

Affected product: ChurchCRM CRM. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58409/ (Markdown: https://insights.sbomify.com/CVE-2026-58409/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58409
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58409
- OSV: https://osv.dev/vulnerability/CVE-2026-58409

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58409/
Summaries are generated and may contain mistakes; the official description above is the record.
