{"answers":{"affected":"2 open source packages ship an affected version, including 9router.","exploited":"There is no known exploitation of CVE-2026-5842 in the wild and no public exploit code.","fix":"Upgrade 9router to 0.3.75 or later.","what":"CVE-2026-5842 is a medium-severity authentication bypass vulnerability in decolua 9router, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-5842 and fix it if it is affected.\n\nWhat it is: CVE-2026-5842 is a medium-severity authentication bypass vulnerability in decolua 9router, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-5842 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- 9router (npm): affected all versions; fixed in 0.3.75\n- 9router (npm): affected all versions; fixed in 0.3.75\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-5842/ (Markdown: https://insights.sbomify.com/CVE-2026-5842/index.md)","id":"CVE-2026-5842","markdown":"https://insights.sbomify.com/CVE-2026-5842/index.md","name":"CVE-2026-5842","record":{"aliases":["GHSA-xrrh-p7f2-27vm"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"9router API","requires_auth":"none","summary":"Remote attackers can bypass authorization on the 9router Administrative API endpoint, requiring an upgrade to secure the system.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"},{"id":"CWE-285","name":"Improper Authorization"}],"description":"A security vulnerability has been detected in decolua 9router up to 0.3.47. The impacted element is an unknown function of the file /api of the component Administrative API Endpoint. The manipulation leads to authorization bypass. The attack is possible to be carried out remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 0.3.75 is sufficient to resolve this issue. It is suggested to upgrade the affected component.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"decolua 9router Administrative API Endpoint api authorization","id":"CVE-2026-5842","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":8,"next":{"headline":"Docker Model Runner container-to-host code execution via MLX-LM model_file importlib loading","id":"CVE-2026-5843"},"packages":[{"ecosystem":"npm","fixed":["0.3.75"],"introduced":["0"],"last_affected":[],"package":"9router","purl":null,"source":"GHSA-xrrh-p7f2-27vm"},{"ecosystem":"npm","fixed":["0.3.75"],"introduced":["0"],"last_affected":[],"package":"9router","purl":"pkg:npm/9router","source":"GHSA-xrrh-p7f2-27vm"}],"prev":{"headline":"Tenda i3 HTTP R7WebsSecurityHandler path traversal","id":"CVE-2026-5841"},"products":["9router"],"published":"2026-04-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-13","vendors":["decolua"]},"summary":"Remote attackers can bypass authorization on the 9router Administrative API endpoint, requiring an upgrade to secure the system.","url":"https://insights.sbomify.com/CVE-2026-5842/"}