# CVE-2026-5842: decolua 9router Administrative API Endpoint api authorization

> Remote attackers can bypass authorization on the 9router Administrative API endpoint, requiring an upgrade to secure the system.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2026
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-xrrh-p7f2-27vm

## What is CVE-2026-5842?

CVE-2026-5842 is a medium-severity authentication bypass vulnerability in decolua 9router, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A security vulnerability has been detected in decolua 9router up to 0.3.47. The impacted element is an unknown function of the file /api of the component Administrative API Endpoint. The manipulation leads to authorization bypass. The attack is possible to be carried out remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 0.3.75 is sufficient to resolve this issue. It is suggested to upgrade the affected component.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-5842?

2 open source packages ship an affected version, including 9router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `9router` | npm | All versions | 0.3.75 |
| `9router` | npm | All versions | 0.3.75 |

## How do I fix CVE-2026-5842?

Upgrade 9router to 0.3.75 or later.

## Is CVE-2026-5842 being exploited?

There is no known exploitation of CVE-2026-5842 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-5842 and fix it if it is affected.

What it is: CVE-2026-5842 is a medium-severity authentication bypass vulnerability in decolua 9router, published on 9 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-5842 in the wild and no public exploit code.

Affected packages and fixed versions:
- 9router (npm): affected all versions; fixed in 0.3.75
- 9router (npm): affected all versions; fixed in 0.3.75

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-5842/ (Markdown: https://insights.sbomify.com/CVE-2026-5842/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-5842
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-5842
- OSV: https://osv.dev/vulnerability/CVE-2026-5842

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-5842/
Summaries are generated and may contain mistakes; the official description above is the record.
