# CVE-2026-58421: Unauthenticated ReDoS via CODEOWNERS pattern matching allows denial of service

> Unauthenticated attackers can cause denial of service in Gitea by exploiting ReDoS vulnerabilities in CODEOWNERS pattern matching.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-v96j-25gv-g2w9, GO-2026-6077

## What is CVE-2026-58421?

CVE-2026-58421 is a high-severity denial of service vulnerability in Gitea Open Source Git Server, published on 3 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Unauthenticated ReDoS via CODEOWNERS pattern matching allows denial of service

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-58421?

3 open source packages ship an affected version, including code.gitea.io/gitea.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | All versions | 1.26.4 |
| `code.gitea.io/gitea` | Go | All versions | 1.26.4 |
| `code.gitea.io/gitea` | Go | All versions | 1.26.4 |

## How do I fix CVE-2026-58421?

Upgrade code.gitea.io/gitea to 1.26.4 or later.

## Is CVE-2026-58421 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58421 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58421 and fix it if it is affected.

What it is: CVE-2026-58421 is a high-severity denial of service vulnerability in Gitea Open Source Git Server, published on 3 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58421 exists.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.26.4
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.26.4
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.26.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58421/ (Markdown: https://insights.sbomify.com/CVE-2026-58421/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58421
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58421
- OSV: https://osv.dev/vulnerability/CVE-2026-58421

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58421/
Summaries are generated and may contain mistakes; the official description above is the record.
