# CVE-2026-58423: LFS authentication bypass via malformed SSH sub-verb allows unauthorized read access to private repositories

> Attackers can bypass authentication via malformed SSH sub-verbs to read private repositories in Gitea Git servers.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-7wvc-rvp7-w99x, GO-2026-6046

## What is CVE-2026-58423?

CVE-2026-58423 is a high-severity authentication bypass vulnerability in Gitea Open Source Git Server, published on 3 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LFS authentication bypass via malformed SSH sub-verb allows unauthorized read access to private repositories

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-58423?

3 open source packages ship an affected version, including code.gitea.io/gitea.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | From 1.23.0 | 1.26.3 |
| `code.gitea.io/gitea` | Go | From 1.23.0 | 1.26.3 |
| `code.gitea.io/gitea` | Go | From 1.23.0 | 1.26.3 |

## How do I fix CVE-2026-58423?

Upgrade code.gitea.io/gitea to 1.26.3 or later.

## Is CVE-2026-58423 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58423 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58423 and fix it if it is affected.

What it is: CVE-2026-58423 is a high-severity authentication bypass vulnerability in Gitea Open Source Git Server, published on 3 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58423 exists.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected from 1.23.0; fixed in 1.26.3
- code.gitea.io/gitea (Go): affected from 1.23.0; fixed in 1.26.3
- code.gitea.io/gitea (Go): affected from 1.23.0; fixed in 1.26.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58423/ (Markdown: https://insights.sbomify.com/CVE-2026-58423/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58423
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58423
- OSV: https://osv.dev/vulnerability/CVE-2026-58423

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58423/
Summaries are generated and may contain mistakes; the official description above is the record.
