# CVE-2026-58427: Private org member list leaked via /members API endpoint — incomplete fix for PR #38145

> Attackers can view private organization member lists via the /members API endpoint due to an incomplete security fix in Gitea.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-prr9-9mp4-5gp2, GO-2026-6068

## What is CVE-2026-58427?

CVE-2026-58427 is a high-severity vulnerability in Gitea Open Source Git Server, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Private org member list leaked via /members API endpoint — incomplete fix for PR #38145

Weakness: CWE-863 (Incorrect Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-58427?

3 open source packages ship an affected version, including gitea.dev.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitea.dev` | Go | All versions | 1.27.0 |
| `gitea.dev` | Go | All versions | 1.27.0 |
| `gitea.dev` | Go | All versions | 1.27.0 |

## How do I fix CVE-2026-58427?

Upgrade gitea.dev to 1.27.0 or later.

## Is CVE-2026-58427 being exploited?

There is no known exploitation of CVE-2026-58427 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58427 and fix it if it is affected.

What it is: CVE-2026-58427 is a high-severity vulnerability in Gitea Open Source Git Server, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-58427 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitea.dev (Go): affected all versions; fixed in 1.27.0
- gitea.dev (Go): affected all versions; fixed in 1.27.0
- gitea.dev (Go): affected all versions; fixed in 1.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58427/ (Markdown: https://insights.sbomify.com/CVE-2026-58427/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58427
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58427
- OSV: https://osv.dev/vulnerability/CVE-2026-58427

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58427/
Summaries are generated and may contain mistakes; the official description above is the record.
