# CVE-2026-58436: ParseAcceptLanguage quadratic-time DoS via Locale middleware on unauthenticated requests

> Attackers can cause denial of service in Gitea by sending crafted Accept-Language headers to unauthenticated endpoints, triggering quadratic-time parsing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-fw57-jgch-pgf3, GO-2026-6055, MINI-68qj-cqgp-8pjv, MINI-prj2-vpfp-8v88

## What is CVE-2026-58436?

CVE-2026-58436 is a high-severity denial of service vulnerability in Gitea Open Source Git Server, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ParseAcceptLanguage quadratic-time DoS via Locale middleware on unauthenticated requests

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-58436?

3 open source packages ship an affected version, including code.gitea.io/gitea and gitea.dev.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | All versions | 1.27.0 |
| `code.gitea.io/gitea` | Go | All versions | 1.27.0 |
| `gitea.dev` | Go | All versions | 1.27.0 |

## How do I fix CVE-2026-58436?

Upgrade code.gitea.io/gitea to 1.27.0 or later.

## Is CVE-2026-58436 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58436 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58436 and fix it if it is affected.

What it is: CVE-2026-58436 is a high-severity denial of service vulnerability in Gitea Open Source Git Server, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58436 exists.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.27.0
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.27.0
- gitea.dev (Go): affected all versions; fixed in 1.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58436/ (Markdown: https://insights.sbomify.com/CVE-2026-58436/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58436
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58436
- OSV: https://osv.dev/vulnerability/CVE-2026-58436

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58436/
Summaries are generated and may contain mistakes; the official description above is the record.
