{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-58469 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2026-58469 is a high-severity memory corruption vulnerability in gnuwget wget, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-58469 and fix it if it is affected.\n\nWhat it is: CVE-2026-58469 is a high-severity memory corruption vulnerability in gnuwget wget, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-58469 in the wild and no public exploit code.\n\nAffected product: gnuwget wget. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-58469/ (Markdown: https://insights.sbomify.com/CVE-2026-58469/index.md)","id":"CVE-2026-58469","markdown":"https://insights.sbomify.com/CVE-2026-58469/index.md","name":"CVE-2026-58469","record":{"aliases":["DEBIAN-CVE-2026-58469","ECHO-019f-ed29-0163","GHSA-fxf9-rxpj-26gx","JLSEC-2026-1158","ROOT-OS-ALPINE-322-CVE-2026-58469","ROOT-OS-ALPINE-323-CVE-2026-58469","ROOT-OS-DEBIAN-11-CVE-2026-58469","ROOT-OS-DEBIAN-12-CVE-2026-58469","ROOT-OS-DEBIAN-13-CVE-2026-58469","SUSE-SU-2026:3337-1","UBUNTU-CVE-2026-58469"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"GNU Wget utility","requires_auth":"none","summary":"A heap buffer underread in GNU Wget allows a malicious server to cause memory corruption and potential code execution via a crafted Metalink URL.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"wget","vendor":"gnu"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"GNU Wget through 1.25.0, fixed in commit 37a40fc, contains a heap buffer underread vulnerability in the clean_metalink_string() function within src/metalink.c that allows a malicious server to trigger memory corruption by serving a Metalink document containing a whitespace-only URL. Attackers can cause the function to decrement a pointer past the start of the buffer when processing an all-whitespace Metalink URL, potentially leading to abnormal program behavior.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP7"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GNU Wget 1.25.0 Heap Buffer Underread via Metalink URL Parsing","id":"CVE-2026-58469","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"GNU Wget 1.25.0 Integer Overflow via Content-Range Header Parsing","id":"CVE-2026-58470"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP7","fixed":["1.24.5-150700.3.6.1"],"introduced":["0"],"last_affected":[],"package":"wget","purl":"pkg:rpm/suse/wget\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP7","source":"SUSE-SU-2026:3337-1"}],"prev":{"headline":"NocoBase 2.1.20 Server-Side Request Forgery via serverRequest wrapper","id":"CVE-2026-58468"},"products":["wget"],"published":"2026-07-07","related":[{"cvss_score":9.8,"headline":"Memory corruption in GNU Wget","id":"CVE-2019-5953","kev_date_added":null,"published":"2019-05-17"},{"cvss_score":9.3,"headline":"Path traversal in n/a","id":"CVE-2014-4877","kev_date_added":null,"published":"2014-10-29"},{"cvss_score":9.1,"headline":"Other in n/a","id":"CVE-2024-38428","kev_date_added":null,"published":"2024-06-16"},{"cvss_score":8.1,"headline":"Race condition in n/a","id":"CVE-2016-7098","kev_date_added":null,"published":"2016-09-26"},{"cvss_score":7.8,"headline":"Information disclosure in n/a","id":"CVE-2018-20483","kev_date_added":null,"published":"2018-12-26"},{"cvss_score":6.9,"headline":"GNU Wget 1.25.0 Integer Overflow via Content-Range Header Parsing","id":"CVE-2026-58470","kev_date_added":null,"published":"2026-07-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-14","vendors":["gnuwget"]},"summary":"A heap buffer underread in GNU Wget allows a malicious server to cause memory corruption and potential code execution via a crafted Metalink URL.","url":"https://insights.sbomify.com/CVE-2026-58469/"}