CVE-2026-58473 Cognee < 1.2.0 Unauthorized LLM Configuration Overwrite via /api/v1/settings

Critical 9.3 Published Updated

Unauthenticated attackers can overwrite LLM settings to redirect operations, enabling data exfiltration from all users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-58473?

CVE-2026-58473 is a critical missing authorization vulnerability in topoteretes cognee, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Cognee before 1.2.0 contains an improper access control vulnerability that allows unauthenticated attackers to overwrite the global LLM provider configuration by self-registering an account and calling the settings endpoint, which performs no admin or superuser check. Attackers can redirect all LLM operations instance-wide to an attacker-controlled endpoint by exploiting the process-wide singleton configuration cache, enabling exfiltration of prompts, uploaded documents, extracted entities, and knowledge graph content from all users.

Weakness: CWE-862, CWE-306

Which versions are affected by CVE-2026-58473?

3 open source packages ship an affected version, including cognee.

PackageAffectedFixed in
cognee PyPIAll versions1.5.0
cognee PyPIAll versions1.5.0
cognee PyPIAll versions1.5.0

How do I fix CVE-2026-58473?

Upgrade cognee to 1.5.0 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-58473 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58473 exists.

Sources

Also known as GHSA-49f7-whx5-4256, PYSEC-2026-3816.

Is CVE-2026-58473 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free