{"answers":{"affected":"3 open source packages ship an affected version, including cognee.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58473 exists.","fix":"Upgrade cognee to 1.5.0 or later.","what":"CVE-2026-58473 is a critical missing authorization vulnerability in topoteretes cognee, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-58473 and fix it if it is affected.\n\nWhat it is: CVE-2026-58473 is a critical missing authorization vulnerability in topoteretes cognee, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58473 exists.\n\nAffected packages and fixed versions:\n- cognee (PyPI): affected all versions; fixed in 1.5.0\n- cognee (PyPI): affected all versions; fixed in 1.5.0\n- cognee (PyPI): affected all versions; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-58473/ (Markdown: https://insights.sbomify.com/CVE-2026-58473/index.md)","id":"CVE-2026-58473","markdown":"https://insights.sbomify.com/CVE-2026-58473/index.md","name":"CVE-2026-58473","record":{"aliases":["GHSA-49f7-whx5-4256","PYSEC-2026-3816"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Cognee LLM application","requires_auth":"none","summary":"Unauthenticated attackers can overwrite LLM settings to redirect operations, enabling data exfiltration from all users.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"Cognee before 1.2.0 contains an improper access control vulnerability that allows unauthenticated attackers to overwrite the global LLM provider configuration by self-registering an account and calling the settings endpoint, which performs no admin or superuser check. Attackers can redirect all LLM operations instance-wide to an attacker-controlled endpoint by exploiting the process-wide singleton configuration cache, enabling exfiltration of prompts, uploaded documents, extracted entities, and knowledge graph content from all users.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cognee \u003c 1.2.0 Unauthorized LLM Configuration Overwrite via /api/v1/settings","id":"CVE-2026-58473","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"whichllm \u003c 0.5.16 Code Injection via run and snippet commands","id":"CVE-2026-58474"},"packages":[{"ecosystem":"PyPI","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"cognee","purl":null,"source":"GHSA-49f7-whx5-4256"},{"ecosystem":"PyPI","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"cognee","purl":"pkg:pypi/cognee","source":"GHSA-49f7-whx5-4256"},{"ecosystem":"PyPI","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"cognee","purl":"pkg:pypi/cognee","source":"PYSEC-2026-3816"}],"prev":{"headline":"GNU Wget 1.25.0 Heap Buffer Overflow via HTML Attribute Encoding","id":"CVE-2026-58472"},"products":["cognee"],"published":"2026-07-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["topoteretes"]},"summary":"Unauthenticated attackers can overwrite LLM settings to redirect operations, enabling data exfiltration from all users.","url":"https://insights.sbomify.com/CVE-2026-58473/"}