# CVE-2026-58473: Cognee < 1.2.0 Unauthorized LLM Configuration Overwrite via /api/v1/settings

> Unauthenticated attackers can overwrite LLM settings to redirect operations, enabling data exfiltration from all users.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-49f7-whx5-4256, PYSEC-2026-3816

## What is CVE-2026-58473?

CVE-2026-58473 is a critical missing authorization vulnerability in topoteretes cognee, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cognee before 1.2.0 contains an improper access control vulnerability that allows unauthenticated attackers to overwrite the global LLM provider configuration by self-registering an account and calling the settings endpoint, which performs no admin or superuser check. Attackers can redirect all LLM operations instance-wide to an attacker-controlled endpoint by exploiting the process-wide singleton configuration cache, enabling exfiltration of prompts, uploaded documents, extracted entities, and knowledge graph content from all users.

Weakness: CWE-862 (Missing Authorization), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-58473?

3 open source packages ship an affected version, including cognee.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cognee` | PyPI | All versions | 1.5.0 |
| `cognee` | PyPI | All versions | 1.5.0 |
| `cognee` | PyPI | All versions | 1.5.0 |

## How do I fix CVE-2026-58473?

Upgrade cognee to 1.5.0 or later.

## Is CVE-2026-58473 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58473 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58473 and fix it if it is affected.

What it is: CVE-2026-58473 is a critical missing authorization vulnerability in topoteretes cognee, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58473 exists.

Affected packages and fixed versions:
- cognee (PyPI): affected all versions; fixed in 1.5.0
- cognee (PyPI): affected all versions; fixed in 1.5.0
- cognee (PyPI): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58473/ (Markdown: https://insights.sbomify.com/CVE-2026-58473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58473
- OSV: https://osv.dev/vulnerability/CVE-2026-58473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58473/
Summaries are generated and may contain mistakes; the official description above is the record.
