CVE-2026-58482 Network-AI: ApprovalInbox HTTP server has no authentication — anyone can approve pending agent actions

Medium 5.9 Published Updated

Unauthenticated HTTP endpoints in Network-AI allow attackers to bypass human-in-the-loop controls and execute high-risk agent actions without consent.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-58482?

CVE-2026-58482 is a medium-severity missing authorization vulnerability in Jovancoding Network-AI, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Network-AI, a TypeScript/Node.js multi-agent orchestrator, has a shipped, exported, documented feature called `ApprovalInbox` (`lib/approval-inbox.ts`). It is the network surface of the human-in-the-loop Approval Gate, which `ApprovalGate` uses to require explicit human approval for high-risk operations. The HTTP server it exposes has no authentication of any kind and sets `Access-Control-Allow-Origin: *` on every route, including the state-changing `POST /approvals/:id/approve` and `/deny`. As a result, in versions 5.0.0 through 5.12.1, any party who can send an HTTP request to the inbox port — a co-located process, a container/SSRF on the same host, a remote client when the operator binds a non-loopback address, or any website the operator visits in a browser (via the wildcard CORS) — can enumerate pending approvals and approve them, defeating the entire human-in-the-loop control and causing the gated high-risk action (e.g. a shell command the agent was holding for review) to execute without consent. This issue is fixed in v5.12.2. `ApprovalInbox` now accepts a `secret` option. When set, the mutating endpoints `POST /:id/approve` and `POST /:id/deny` require an `Authorization: Bearer <secret>` header, validated in constant time with `crypto.timingSafeEqual`. `startServer()` already binds to `127.0.0.1` by default; operators exposing the inbox on a network must set a secret.

Weakness: CWE-862, CWE-352

Which versions are affected by CVE-2026-58482?

2 open source packages ship an affected version, including network-ai. It affects 1 product.

PackageAffectedFixed in
network-ai npmFrom 5.0.05.12.2
network-ai npmFrom 5.0.05.12.2

Products include Network-Ai Network-Ai.

How do I fix CVE-2026-58482?

Upgrade network-ai to 5.12.2 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-58482 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58482 exists.

Sources

Also known as GHSA-mxjx-28vx-xjjj.

Is CVE-2026-58482 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free