# CVE-2026-58484: Network-AI: Poisoned environment backup manifest allows arbitrary recursive deletion during backup pruning

> An attacker can delete arbitrary files by poisoning a backup manifest, leading to data loss or service disruption in Network-AI.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-2fmp-9rvw-hc96

## What is CVE-2026-58484?

CVE-2026-58484 is a high-severity path traversal vulnerability in Jovancoding Network-AI, published on 20 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Network-AI is a TypeScript/Node.js multi-agent orchestrator. Prior to version 5.12.2, `EnvironmentManager.listBackups()` reads each backup's `_manifest.json` and trusts the manifest's `path` field. `EnvironmentManager.pruneBackups()` later passes that trusted `entry.path` directly to `rmSync(entry.path, { recursive: true, force: true })`. An attacker who can place or modify a manifest inside `data/<env>/.backups/<name>/_manifest.json` can cause `network-ai env backup prune --env <env> --keep <n>` or any code path invoking `pruneBackups()` to recursively delete an arbitrary path accessible to the Network-AI process user. This is fixed in v5.12.2. `pruneBackups()` no longer passes `entry.path` from the on-disk manifest to `rmSync`. The deletion path is recomputed from a format-validated `entry.backupId`, and a `dirname` containment check confines deletion to exactly one level under the backups directory. A poisoned manifest (e.g. `"path": "/"`) is now inert.

Weakness: CWE-73 (External Control of File Name or Path), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-58484?

2 open source packages ship an affected version, including network-ai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `network-ai` | npm | All versions | 5.12.2 |
| `network-ai` | npm | All versions | 5.12.2 |

Products: Network-Ai Network-Ai.

## How do I fix CVE-2026-58484?

Upgrade network-ai to 5.12.2 or later.

## Is CVE-2026-58484 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58484 exists.

## Other vulnerabilities in Jovancoding Network-AI

- [CVE-2026-46701](https://insights.sbomify.com/CVE-2026-46701/): Network-AI: Unauthenticated Cross-Origin MCP Tool Invocation via Empty Default Secret (high 7.6)
- [CVE-2026-58481](https://insights.sbomify.com/CVE-2026-58481/): Network-AI: AgentRuntime sandbox path-prefix checks allow file access outside the configured base directory (medium 6.5)
- [CVE-2026-58413](https://insights.sbomify.com/CVE-2026-58413/): EnvironmentManager.restore() backup ID path traversal copies arbitrary directories into environment data (medium 6.1)
- [CVE-2026-58482](https://insights.sbomify.com/CVE-2026-58482/): Network-AI: ApprovalInbox HTTP server has no authentication — anyone can approve pending agent actions (medium 5.9)
- [CVE-2026-58414](https://insights.sbomify.com/CVE-2026-58414/): Network-AI: EnvironmentManager.backup() follows symlinked directories and copies files outside the environment root into backups (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58484 and fix it if it is affected.

What it is: CVE-2026-58484 is a high-severity path traversal vulnerability in Jovancoding Network-AI, published on 20 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58484 exists.

Affected packages and fixed versions:
- network-ai (npm): affected all versions; fixed in 5.12.2
- network-ai (npm): affected all versions; fixed in 5.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58484/ (Markdown: https://insights.sbomify.com/CVE-2026-58484/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58484
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58484
- OSV: https://osv.dev/vulnerability/CVE-2026-58484

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58484/
Summaries are generated and may contain mistakes; the official description above is the record.
