{"answers":{"affected":"3 open source packages ship an affected version, including zeep. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-58501 in the wild and no public exploit code.","fix":"Upgrade zeep to 4.3.3 or later.","what":"CVE-2026-58501 is a medium-severity server-side request forgery vulnerability in mvantellingen python-zeep, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-58501 and fix it if it is affected.\n\nWhat it is: CVE-2026-58501 is a medium-severity server-side request forgery vulnerability in mvantellingen python-zeep, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-58501 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zeep (PyPI): affected from 4.0.0; fixed in 4.3.3\n- zeep (PyPI): affected from 4.0.0; fixed in 4.3.3\n- zeep (PyPI): affected from 4.0.0; fixed in 4.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-58501/ (Markdown: https://insights.sbomify.com/CVE-2026-58501/index.md)","id":"CVE-2026-58501","markdown":"https://insights.sbomify.com/CVE-2026-58501/index.md","name":"CVE-2026-58501","record":{"aliases":["DEBIAN-CVE-2026-58501","GHSA-4cc2-g9w2-fhf6","PYSEC-2026-2323","UBUNTU-CVE-2026-58501"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python SOAP client","requires_auth":"none","summary":"Zeep fails to enforce external resource restrictions, allowing attackers to trigger server-side requests via malicious WSDL or XSD documents.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"zeep","vendor":"python-zeep"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Zeep is a Python SOAP client. From 4.0.0 before 4.3.3, Settings.forbid_external is defined but not enforced when parsing WSDL or XSD documents, allowing transitive xsd:import, xsd:include, wsdl:import, and lxml entity or DTD references to fetch attacker-chosen HTTP or HTTPS URLs. This issue is fixed in version 4.3.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Zeep SSRF because Settings.forbid_external is not enforced","id":"CVE-2026-58501","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"githubtoplanguages: Command Injection via Issue Title in Discord Notification Workflow","id":"CVE-2026-58502"},"packages":[{"ecosystem":"PyPI","fixed":["4.3.3"],"introduced":["4.0.0"],"last_affected":[],"package":"zeep","purl":null,"source":"GHSA-4cc2-g9w2-fhf6"},{"ecosystem":"PyPI","fixed":["4.3.3"],"introduced":["4.0.0"],"last_affected":[],"package":"zeep","purl":"pkg:pypi/zeep","source":"GHSA-4cc2-g9w2-fhf6"},{"ecosystem":"PyPI","fixed":["4.3.3"],"introduced":["4.0.0"],"last_affected":[],"package":"zeep","purl":"pkg:pypi/zeep","source":"PYSEC-2026-2323"}],"prev":{"headline":"MCP Appium: Unescaped Locator Data XSS in MCP-UI Resource (createLocatorGeneratorUI)","id":"CVE-2026-58500"},"products":["python-zeep"],"published":"2026-07-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["mvantellingen"]},"summary":"Zeep fails to enforce external resource restrictions, allowing attackers to trigger server-side requests via malicious WSDL or XSD documents.","url":"https://insights.sbomify.com/CVE-2026-58501/"}