# CVE-2026-58501: Zeep SSRF because Settings.forbid_external is not enforced

> Zeep fails to enforce external resource restrictions, allowing attackers to trigger server-side requests via malicious WSDL or XSD documents.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-58501, GHSA-4cc2-g9w2-fhf6, PYSEC-2026-2323, UBUNTU-CVE-2026-58501

## What is CVE-2026-58501?

CVE-2026-58501 is a medium-severity server-side request forgery vulnerability in mvantellingen python-zeep, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Zeep is a Python SOAP client. From 4.0.0 before 4.3.3, Settings.forbid_external is defined but not enforced when parsing WSDL or XSD documents, allowing transitive xsd:import, xsd:include, wsdl:import, and lxml entity or DTD references to fetch attacker-chosen HTTP or HTTPS URLs. This issue is fixed in version 4.3.3.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-58501?

3 open source packages ship an affected version, including zeep. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zeep` | PyPI | From 4.0.0 | 4.3.3 |
| `zeep` | PyPI | From 4.0.0 | 4.3.3 |
| `zeep` | PyPI | From 4.0.0 | 4.3.3 |

Products: Python-Zeep Zeep.

## How do I fix CVE-2026-58501?

Upgrade zeep to 4.3.3 or later.

## Is CVE-2026-58501 being exploited?

There is no known exploitation of CVE-2026-58501 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58501 and fix it if it is affected.

What it is: CVE-2026-58501 is a medium-severity server-side request forgery vulnerability in mvantellingen python-zeep, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-58501 in the wild and no public exploit code.

Affected packages and fixed versions:
- zeep (PyPI): affected from 4.0.0; fixed in 4.3.3
- zeep (PyPI): affected from 4.0.0; fixed in 4.3.3
- zeep (PyPI): affected from 4.0.0; fixed in 4.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58501/ (Markdown: https://insights.sbomify.com/CVE-2026-58501/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58501
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58501
- OSV: https://osv.dev/vulnerability/CVE-2026-58501

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58501/
Summaries are generated and may contain mistakes; the official description above is the record.
