{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-58587 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-58587 is a medium-severity cross-site scripting vulnerability in Drupal Canvas, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-58587 and fix it if it is affected.\n\nWhat it is: CVE-2026-58587 is a medium-severity cross-site scripting vulnerability in Drupal Canvas, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-58587 in the wild and no public exploit code.\n\nAffected product: Drupal Canvas. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-58587/ (Markdown: https://insights.sbomify.com/CVE-2026-58587/index.md)","id":"CVE-2026-58587","markdown":"https://insights.sbomify.com/CVE-2026-58587/index.md","name":"CVE-2026-58587","record":{"aliases":["DRUPAL-CONTRIB-2026-065","GHSA-vx3g-w5hr-294x"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Canvas module","requires_auth":"none","summary":"Attackers can inject malicious scripts via improper input validation in the Drupal Canvas module, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"drupal_canvas","vendor":"drupal_canvas_project"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation (\"Cross-site Scripting\") vulnerability in Drupal Drupal Canvas allows Cross-Site Scripting (XSS). This issue affects Drupal Canvas versions: from 0.0.0 to 1.4.2, from 1.5.0 to 1.5.2, from 1.6.0 to 1.6.1, from 1.7.0 to 1.7.1.","ecosystems":["Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Drupal Canvas - Moderately critical - Improper validation - SA-CONTRIB-2026-065","id":"CVE-2026-58587","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Drupal Canvas - Moderately critical - Improper validation - SA-CONTRIB-2026-066","id":"CVE-2026-58588"},"packages":[{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["1.4.2","1.5.2","1.6.1","1.7.1"],"introduced":["0","1.5.0","1.6.0","1.7.0"],"last_affected":[],"package":"drupal/canvas","purl":"pkg:composer/drupal/canvas?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2026-065"}],"prev":{"headline":"Image::WebP versions before 0.3.0 for Perl bundle a vulnerable version of libwebp","id":"CVE-2026-58586"},"products":["Drupal Canvas"],"published":"2026-07-10","related":[{"cvss_score":6.1,"headline":"Drupal Canvas - Moderately critical - Improper validation - SA-CONTRIB-2026-066","id":"CVE-2026-58588","kev_date_added":null,"published":"2026-07-10"},{"cvss_score":5,"headline":"Drupal Canvas - Moderately critical - Server-side request forgery, Information disclosure - SA-CONTRIB-2026-017","id":"CVE-2026-3216","kev_date_added":null,"published":"2026-03-25"},{"cvss_score":4.8,"headline":"Drupal Canvas - Moderately critical - Access bypass - SA-CONTRIB-2026-006","id":"CVE-2026-1553","kev_date_added":null,"published":"2026-02-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-13","vendors":["Drupal"]},"summary":"Attackers can inject malicious scripts via improper input validation in the Drupal Canvas module, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2026-58587/"}