# CVE-2026-58659: PyTorch Lightning Arbitrary Code Execution via _instantiator Hyperparameter

> Attackers can execute arbitrary code by crafting malicious checkpoint files that bypass security protections in PyTorch Lightning.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-qqmf-gpg7-g8gw, PYSEC-2026-3624, PYSEC-2026-3967

## What is CVE-2026-58659?

CVE-2026-58659 is a high-severity code injection vulnerability in Lightning-AI pytorch-lightning, published on 15 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PyTorch Lightning through 2.6.5, fixed in commit d710d68, contains a remote code execution vulnerability in the _load_state function that imports and executes attacker-controlled module names from checkpoint _instantiator hyperparameters. Attackers can craft malicious checkpoint files that bypass weights_only=True protections to execute arbitrary code when LightningModule.load_from_checkpoint is called.

Weakness: CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2026-58659?

4 open source packages ship an affected version, including pytorch-lightning and lightning. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pytorch-lightning` | PyPI | All versions | 2.6.6 |
| `lightning` | PyPI | All versions | 2.6.6 |
| `lightning` | PyPI | All versions | 2.6.6 |
| `lightning` | PyPI | All versions | 2.6.6 |

Products: Lightningai Pytorch Lightning.

## How do I fix CVE-2026-58659?

Upgrade pytorch-lightning to 2.6.6 or later.

## Is CVE-2026-58659 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58659 exists.

## Other vulnerabilities in Lightning-AI pytorch-lightning

- [CVE-2024-5452](https://insights.sbomify.com/CVE-2024-5452/): RCE via Property/Class Pollution in lightning-ai/pytorch-lightning (critical 9.8)
- [CVE-2026-44484](https://insights.sbomify.com/CVE-2026-44484/): Compromise of PyTorch Lightning PyPi Package Versions (critical 9.3)
- [CVE-2024-8019](https://insights.sbomify.com/CVE-2024-8019/): Arbitrary File Write/Overwrite in lightning-ai/pytorch-lightning (critical 9.1)
- [CVE-2024-5980](https://insights.sbomify.com/CVE-2024-5980/): Arbitrary File Write via /v1/runs API endpoint in lightning-ai/pytorch-lightning (critical 9.1)
- [CVE-2026-31221](https://insights.sbomify.com/CVE-2026-31221/): PyTorch Lightning load_from_checkpoint has an insecure checkpoint deserialization (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-58659 and fix it if it is affected.

What it is: CVE-2026-58659 is a high-severity code injection vulnerability in Lightning-AI pytorch-lightning, published on 15 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-58659 exists.

Affected packages and fixed versions:
- pytorch-lightning (PyPI): affected all versions; fixed in 2.6.6
- lightning (PyPI): affected all versions; fixed in 2.6.6
- lightning (PyPI): affected all versions; fixed in 2.6.6
- lightning (PyPI): affected all versions; fixed in 2.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-58659/ (Markdown: https://insights.sbomify.com/CVE-2026-58659/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-58659
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-58659
- OSV: https://osv.dev/vulnerability/CVE-2026-58659

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-58659/
Summaries are generated and may contain mistakes; the official description above is the record.
