CVE-2026-59084 Apache Tomcat: EncryptInterceptor requirements not clearly documented
Insufficient documentation for EncryptInterceptor may lead to insecure configurations, allowing attackers to bypass intended security controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-59084?
CVE-2026-59084 is a critical vulnerability in Apache Tomcat, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Other versions that have reached end of support may also be affected.
Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue.
Weakness: CWE-1059
Which versions are affected by CVE-2026-59084?
1 open source package ship an affected version, including tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tomcat Bitnami | From 7.0.100 | 9.0.120, 10.1.57, 11.0.24 |
Products include Apache Tomcat.
How do I fix CVE-2026-59084?
Upgrade tomcat to a fixed version for your release line: 9.0.120, 10.1.57 or 11.0.24.
Is CVE-2026-59084 being exploited?
There is no known exploitation of CVE-2026-59084 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2026-59084, DEBIAN-CVE-2026-59084, GHSA-cwxf-7cw2-7r32, MINI-395q-5g63-hhgj, MINI-9fjp-q82f-7pcc, MINI-m493-9v8h-q24h and 1 more.