# CVE-2026-59084: Apache Tomcat: EncryptInterceptor requirements not clearly documented

> Insufficient documentation for EncryptInterceptor may lead to insecure configurations, allowing attackers to bypass intended security controls.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** BIT-tomcat-2026-59084, DEBIAN-CVE-2026-59084, GHSA-cwxf-7cw2-7r32, MINI-395q-5g63-hhgj, MINI-9fjp-q82f-7pcc, MINI-m493-9v8h-q24h, UBUNTU-CVE-2026-59084

## What is CVE-2026-59084?

CVE-2026-59084 is a critical vulnerability in Apache Tomcat, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Other versions that have reached end of support may also be affected.

Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue.

Weakness: CWE-1059 (Insufficient Technical Documentation)

## Which versions are affected by CVE-2026-59084?

1 open source package ship an affected version, including tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tomcat` | Bitnami | From 7.0.100 | 9.0.120, 10.1.57, 11.0.24 |

Products: Apache Tomcat.

## How do I fix CVE-2026-59084?

Upgrade tomcat to a fixed version for your release line: 9.0.120, 10.1.57 or 11.0.24.

## Is CVE-2026-59084 being exploited?

There is no known exploitation of CVE-2026-59084 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59084 and fix it if it is affected.

What it is: CVE-2026-59084 is a critical vulnerability in Apache Tomcat, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59084 in the wild and no public exploit code.

Affected packages and fixed versions:
- tomcat (Bitnami): affected from 7.0.100; fixed in 9.0.120, 10.1.57, 11.0.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59084/ (Markdown: https://insights.sbomify.com/CVE-2026-59084/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59084
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59084
- OSV: https://osv.dev/vulnerability/CVE-2026-59084

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59084/
Summaries are generated and may contain mistakes; the official description above is the record.
