# CVE-2026-59151: Prowler: SAML Domain Claiming Enables Cross-Tenant Account Takeover

> An attacker with a controlled SAML IdP can claim another tenant's domain to obtain valid tokens and achieve cross-tenant account takeover.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 13 Jul 2026

## What is CVE-2026-59151?

CVE-2026-59151 is a critical authentication bypass vulnerability in prowler-cloud prowler, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Prowler is a cloud security platform. Prior to 5.30.3, Prowler's SAML authentication flow trusted the email domain asserted in a SAMLResponse when deciding which tenant should receive the final token, and the ACS finish logic in api/src/backend/api/v1/views.py recalculated the tenant from user.email instead of binding token issuance to the validated SAML configuration. An authenticated attacker with a controlled SAML IdP could complete a valid SAML flow for an attacker-controlled domain while asserting an email address from another configured domain, causing a SAMLToken and tenant-scoped JWT to be issued for the wrong tenant and enabling cross-tenant account takeover. This issue is fixed in version 5.30.3.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-59151?

It affects 1 product.


Products: Prowler Prowler.

## How do I fix CVE-2026-59151?

Upgrade to a fixed version.

## Is CVE-2026-59151 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59151 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59151 and fix it if it is affected.

What it is: CVE-2026-59151 is a critical authentication bypass vulnerability in prowler-cloud prowler, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59151 exists.

Affected product: prowler-cloud prowler. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59151/ (Markdown: https://insights.sbomify.com/CVE-2026-59151/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59151
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59151
- OSV: https://osv.dev/vulnerability/CVE-2026-59151

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59151/
Summaries are generated and may contain mistakes; the official description above is the record.
