{"answers":{"affected":"2 open source packages ship an affected version, including langsmith.","exploited":"There is no known exploitation of CVE-2026-59152 in the wild and no public exploit code.","fix":"Upgrade langsmith to 0.8.18 or later.","what":"CVE-2026-59152 is a medium-severity path traversal vulnerability in langchain-ai langsmith-sdk, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-59152 and fix it if it is affected.\n\nWhat it is: CVE-2026-59152 is a medium-severity path traversal vulnerability in langchain-ai langsmith-sdk, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-59152 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- langsmith (PyPI): affected all versions; fixed in 0.8.18\n- langsmith (PyPI): affected all versions; fixed in 0.8.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59152/ (Markdown: https://insights.sbomify.com/CVE-2026-59152/index.md)","id":"CVE-2026-59152","markdown":"https://insights.sbomify.com/CVE-2026-59152/index.md","name":"CVE-2026-59152","record":{"aliases":["CLEANSTART-2026-DI87779","CLEANSTART-2026-EU68751","CLEANSTART-2026-TL07655","ECHO-981d-76df-3620","GHSA-f4xh-w4cj-qxq8","ROOT-APP-PYPI-GHSA-f4xh-w4cj-qxq8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"LangSmith SDK","requires_auth":"low_privilege","summary":"An attacker can force a server using LangSmith SDK TracingMiddleware to read arbitrary local files and exfiltrate them to a LangSmith workspace.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-843","name":"Access of Resource Using Incompatible Type"},{"id":"CWE-346","name":"Origin Validation Error"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"LangSmith Client SDKs provide SDK's for interacting with the LangSmith platform. Prior to 0.8.18, an attacker who can send an HTTP request to a server running the LangSmith SDK's TracingMiddleware can cause that server to read an arbitrary file from its local filesystem and upload the contents to LangSmith as a trace attachment. Depending on how the distributed trace system is deployed, triggering a read may not require authentication. Retrieving the contents requires read access to the LangSmith workspace the traces are sent to. The net effect is a trust-boundary crossing: a party with workspace trace-read access (for example a low-privilege workspace member, a contractor, or a compromised teammate account) gains the ability to read files from any server running TracingMiddleware, a capability outside that workspace's intended trust boundary. This vulnerability is fixed in 0.8.18.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Arbitrary server-side file read in LangSmith SDK TracingMiddleware","id":"CVE-2026-59152","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Anki's local HTTP server does not sufficiently validate requests","id":"CVE-2026-59153"},"packages":[{"ecosystem":"PyPI","fixed":["0.8.18"],"introduced":["0"],"last_affected":[],"package":"langsmith","purl":null,"source":"GHSA-f4xh-w4cj-qxq8"},{"ecosystem":"PyPI","fixed":["0.8.18"],"introduced":["0"],"last_affected":[],"package":"langsmith","purl":"pkg:pypi/langsmith","source":"GHSA-f4xh-w4cj-qxq8"}],"prev":{"headline":"Prowler: SAML Domain Claiming Enables Cross-Tenant Account Takeover","id":"CVE-2026-59151"},"products":["langsmith-sdk"],"published":"2026-07-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-07","vendors":["langchain-ai"]},"summary":"An attacker can force a server using LangSmith SDK TracingMiddleware to read arbitrary local files and exfiltrate them to a LangSmith workspace.","url":"https://insights.sbomify.com/CVE-2026-59152/"}