CVE-2026-59153 Anki's local HTTP server does not sufficiently validate requests

Low 2.1 Published Updated

A malicious website can trigger side-effecting requests to Anki's local HTTP server due to insufficient origin validation, potentially modifying data or bypassing security controls.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-59153?

CVE-2026-59153 is a low-severity vulnerability in ankitects anki, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, Anki launches a local HTTP server to serve media files and web pages for parts of its interface, but requests from other origins were not sufficiently blocked. A malicious website could potentially trigger side-effecting requests to the local server, with severity varying by browser depending on Private Network Access protections. This issue is fixed in version 25.09.3.

Weakness: CWE-346

Which versions are affected by CVE-2026-59153?

3 open source packages ship an affected version, including aqt.

PackageAffectedFixed in
aqt PyPIAll versions25.9.3
aqt PyPIAll versions25.9.3
aqt PyPIAll versions25.9.3

How do I fix CVE-2026-59153?

Upgrade aqt to 25.9.3 or later.

Is CVE-2026-59153 being exploited?

There is no known exploitation of CVE-2026-59153 in the wild and no public exploit code.

Sources

Also known as GHSA-869j-r97x-hx2g, PYSEC-2026-3459, UBUNTU-CVE-2026-59153.

Is CVE-2026-59153 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free