{"answers":{"affected":"3 open source packages ship an affected version, including aqt.","exploited":"There is no known exploitation of CVE-2026-59153 in the wild and no public exploit code.","fix":"Upgrade aqt to 25.9.3 or later.","what":"CVE-2026-59153 is a low-severity vulnerability in ankitects anki, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-59153 and fix it if it is affected.\n\nWhat it is: CVE-2026-59153 is a low-severity vulnerability in ankitects anki, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-59153 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aqt (PyPI): affected all versions; fixed in 25.9.3\n- aqt (PyPI): affected all versions; fixed in 25.9.3\n- aqt (PyPI): affected all versions; fixed in 25.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59153/ (Markdown: https://insights.sbomify.com/CVE-2026-59153/index.md)","id":"CVE-2026-59153","markdown":"https://insights.sbomify.com/CVE-2026-59153/index.md","name":"CVE-2026-59153","record":{"aliases":["GHSA-869j-r97x-hx2g","PYSEC-2026-3459","UBUNTU-CVE-2026-59153"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Anki flashcard application","requires_auth":"none","summary":"A malicious website can trigger side-effecting requests to Anki's local HTTP server due to insufficient origin validation, potentially modifying data or bypassing security controls.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-346","name":"Origin Validation Error"}],"description":"Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, Anki launches a local HTTP server to serve media files and web pages for parts of its interface, but requests from other origins were not sufficiently blocked. A malicious website could potentially trigger side-effecting requests to the local server, with severity varying by browser depending on Private Network Access protections. This issue is fixed in version 25.09.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Anki's local HTTP server does not sufficiently validate requests","id":"CVE-2026-59153","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"csrf","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Wekan: Checklist direct DDP updates can write checklist data into private boards","id":"CVE-2026-59154"},"packages":[{"ecosystem":"PyPI","fixed":["25.9.3"],"introduced":["0"],"last_affected":[],"package":"aqt","purl":null,"source":"GHSA-869j-r97x-hx2g"},{"ecosystem":"PyPI","fixed":["25.9.3"],"introduced":["0"],"last_affected":[],"package":"aqt","purl":"pkg:pypi/aqt","source":"GHSA-869j-r97x-hx2g"},{"ecosystem":"PyPI","fixed":["25.9.3"],"introduced":["0"],"last_affected":[],"package":"aqt","purl":"pkg:pypi/aqt","source":"PYSEC-2026-3459"}],"prev":{"headline":"Arbitrary server-side file read in LangSmith SDK TracingMiddleware","id":"CVE-2026-59152"},"products":["anki"],"published":"2026-07-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-08","vendors":["ankitects"]},"summary":"A malicious website can trigger side-effecting requests to Anki's local HTTP server due to insufficient origin validation, potentially modifying data or bypassing security controls.","url":"https://insights.sbomify.com/CVE-2026-59153/"}