# CVE-2026-59153: Anki's local HTTP server does not sufficiently validate requests

> A malicious website can trigger side-effecting requests to Anki's local HTTP server due to insufficient origin validation, potentially modifying data or bypassing security controls.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** GHSA-869j-r97x-hx2g, PYSEC-2026-3459, UBUNTU-CVE-2026-59153

## What is CVE-2026-59153?

CVE-2026-59153 is a low-severity vulnerability in ankitects anki, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Anki is a program for creating and reviewing flashcards. Prior to 25.09.3, Anki launches a local HTTP server to serve media files and web pages for parts of its interface, but requests from other origins were not sufficiently blocked. A malicious website could potentially trigger side-effecting requests to the local server, with severity varying by browser depending on Private Network Access protections. This issue is fixed in version 25.09.3.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-59153?

3 open source packages ship an affected version, including aqt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aqt` | PyPI | All versions | 25.9.3 |
| `aqt` | PyPI | All versions | 25.9.3 |
| `aqt` | PyPI | All versions | 25.9.3 |

## How do I fix CVE-2026-59153?

Upgrade aqt to 25.9.3 or later.

## Is CVE-2026-59153 being exploited?

There is no known exploitation of CVE-2026-59153 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59153 and fix it if it is affected.

What it is: CVE-2026-59153 is a low-severity vulnerability in ankitects anki, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-59153 in the wild and no public exploit code.

Affected packages and fixed versions:
- aqt (PyPI): affected all versions; fixed in 25.9.3
- aqt (PyPI): affected all versions; fixed in 25.9.3
- aqt (PyPI): affected all versions; fixed in 25.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59153/ (Markdown: https://insights.sbomify.com/CVE-2026-59153/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59153
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59153
- OSV: https://osv.dev/vulnerability/CVE-2026-59153

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59153/
Summaries are generated and may contain mistakes; the official description above is the record.
