# CVE-2026-59157: webhookd: Unrestricted HTTP Header to Shell Variable Injection

> Attackers can spoof user identity via HTTP headers in unauthenticated webhookd deployments, bypassing security controls to access or modify resources.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-v25g-mvwr-f5fp, GO-2026-6451

## What is CVE-2026-59157?

CVE-2026-59157 is a medium-severity authentication bypass vulnerability in ncarlier webhookd, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

webhookd is a minimalist webhook server that triggers shell scripts and external processes through HTTP requests. Prior to 1.22.0, webhookd deployments without htpasswd authentication forwarded all incoming HTTP headers through HTTPParamsToShellVars in pkg/api/index.go into the hook script environment without an allowlist. When an upstream reverse proxy did not strip a client-supplied X-WebAuthn-User header and a hook script trusted that variable for identity or privilege, a remote unauthenticated attacker could spoof another user, bypass script security controls, and access or modify resources available to the impersonated identity. This issue is fixed in version 1.22.0.

Weakness: CWE-807 (Reliance on Untrusted Inputs in a Security Decision), CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-59157?

3 open source packages ship an affected version, including github.com/ncarlier/webhookd.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ncarlier/webhookd` | Go | All versions | 1.22.0 |
| `github.com/ncarlier/webhookd` | Go | All versions | 1.22.0 |
| `github.com/ncarlier/webhookd` | Go | All versions | 1.22.0 |

## How do I fix CVE-2026-59157?

Upgrade github.com/ncarlier/webhookd to 1.22.0 or later.

## Is CVE-2026-59157 being exploited?

There is no known exploitation of CVE-2026-59157 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59157 and fix it if it is affected.

What it is: CVE-2026-59157 is a medium-severity authentication bypass vulnerability in ncarlier webhookd, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-59157 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ncarlier/webhookd (Go): affected all versions; fixed in 1.22.0
- github.com/ncarlier/webhookd (Go): affected all versions; fixed in 1.22.0
- github.com/ncarlier/webhookd (Go): affected all versions; fixed in 1.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59157/ (Markdown: https://insights.sbomify.com/CVE-2026-59157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59157
- OSV: https://osv.dev/vulnerability/CVE-2026-59157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59157/
Summaries are generated and may contain mistakes; the official description above is the record.
