# CVE-2026-59158: Nuxt Ollama: public runtime configuration discloses the configured cloud API key


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-fxg7-897c-57mp

## What is CVE-2026-59158?

CVE-2026-59158 is a high-severity vulnerability in thoda-dev nuxt-ollama, published on 27 Oct 2026. 

### Official description

Nuxt Ollama integrates the official Ollama JavaScript library into Nuxt applications. Prior to 1.3.1, `src/module.ts` unconditionally merges all module options, including a configured cloud `api_key`, into `runtimeConfig.public.ollama`. Nuxt serializes this public configuration into the server-rendered HTML `window.__NUXT__` payload, exposing the API key in plaintext to any unauthenticated client that fetches a page. `src/runtime/composables/useOllama.ts` also reads the public key and sends it as an `Authorization` `Bearer` credential in browser-side Ollama requests. Following the documented cloud configuration is sufficient; the visible application template need not make an Ollama request for the secret to leak. A stolen key permits unauthorized cloud API requests at the operator's expense, quota or rate-limit exhaustion, and access to stored models or conversations if the key grants those permissions. This issue is fixed in version 1.3.1.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2026-59158?

2 open source packages ship an affected version, including nuxt-ollama.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nuxt-ollama` | npm | From 1.2.26 | 1.3.1 |
| `nuxt-ollama` | npm | From 1.2.26 | 1.3.1 |

## How do I fix CVE-2026-59158?

Upgrade nuxt-ollama to 1.3.1 or later.

## Is CVE-2026-59158 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59158 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59158 and fix it if it is affected.

What it is: CVE-2026-59158 is a high-severity vulnerability in thoda-dev nuxt-ollama, published on 27 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59158 exists.

Affected packages and fixed versions:
- nuxt-ollama (npm): affected from 1.2.26; fixed in 1.3.1
- nuxt-ollama (npm): affected from 1.2.26; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59158/ (Markdown: https://insights.sbomify.com/CVE-2026-59158/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59158
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59158
- OSV: https://osv.dev/vulnerability/CVE-2026-59158

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59158/
Summaries are generated and may contain mistakes; the official description above is the record.
