CVE-2026-59160 Yeger: Unauthenticated Network-Exposed Turborepo Task Execution via /api/run

High 8.8 Published Updated

Unauthenticated attackers can execute arbitrary Turbo tasks via the exposed API, leading to code execution and potential privilege escalation on developer machines.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-59160?

CVE-2026-59160 is a high-severity missing authorization vulnerability in DerYeger yeger, published on 15 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Yeger is a monorepo for npm packages maintained under the yeger scope. Prior to 2.8.9, the turbo-graph package starts its embedded Next.js server from packages/turbo-graph/src/index.ts on all interfaces, including 0.0.0.0:29312 by default, while the GET handler for /api/run in packages/turbo-graph-ui/app/api/run/route.ts has no authentication, authorization, CSRF protection, or task allowlist. The handler accepts the tasks, filter, and force query parameters, and buildResponseFromArgs passes attacker-selected task names to spawn() as Turbo CLI arguments. An adjacent-network attacker can execute any task defined in the victim repository's turbo.json with the privileges of the developer OS user, potentially exposing secrets, modifying files or infrastructure, or causing destructive availability effects. The use of an argument array prevents traditional shell metacharacter injection but does not prevent unauthorized execution of defined tasks. This issue is fixed in version 2.8.9.

Weakness: CWE-306

Which versions are affected by CVE-2026-59160?

2 open source packages ship an affected version, including @yeger/turbo-graph.

PackageAffectedFixed in
@yeger/turbo-graph npmAll versions2.8.12
@yeger/turbo-graph npmAll versions2.8.12

How do I fix CVE-2026-59160?

Upgrade @yeger/turbo-graph to 2.8.12 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-59160 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59160 exists.

Sources

Also known as GHSA-2r5q-h53f-9rp3.

Is CVE-2026-59160 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free