# CVE-2026-59167: SunEditor: Critical XSS vulnerability - sanitizer bypass

> Attackers can execute arbitrary scripts in the victim's browser context via stored XSS by bypassing the editor's sanitizer, leading to data exposure or unauthorized actions.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-6rf4-v2fh-m6p4

## What is CVE-2026-59167?

CVE-2026-59167 is a critical cross-site scripting vulnerability in JiHong88 suneditor, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SunEditor is a lightweight and powerful WYSIWYG editor in vanilla JavaScript with no dependencies. Prior to 2.47.11, the sanitizer in src/lib/core.js does not consistently reject namespaced or custom HTML elements, allowing event-handler attributes to remain on crafted elements. When an application renders attacker-controlled editor content and a user interacts with the element, the retained handler can execute script in the application's browser origin, enabling stored cross-site scripting, data exposure, or unauthorized browser-context actions. This issue is fixed in version 2.47.11.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-59167?

2 open source packages ship an affected version, including suneditor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `suneditor` | npm | All versions | 2.47.11 |
| `suneditor` | npm | All versions | 2.47.11 |

## How do I fix CVE-2026-59167?

Upgrade suneditor to 2.47.11 or later.

## Is CVE-2026-59167 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59167 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59167 and fix it if it is affected.

What it is: CVE-2026-59167 is a critical cross-site scripting vulnerability in JiHong88 suneditor, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59167 exists.

Affected packages and fixed versions:
- suneditor (npm): affected all versions; fixed in 2.47.11
- suneditor (npm): affected all versions; fixed in 2.47.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59167/ (Markdown: https://insights.sbomify.com/CVE-2026-59167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59167
- OSV: https://osv.dev/vulnerability/CVE-2026-59167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59167/
Summaries are generated and may contain mistakes; the official description above is the record.
