CVE-2026-59168 Dasel: Unbounded recursion in JSON and XML readers causes unrecoverable stack-overflow DoS

Medium 6.2 Published Updated

Attackers can crash the application by supplying deeply nested JSON or XML input, causing an unrecoverable stack overflow in the Dasel library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-59168?

CVE-2026-59168 is a medium-severity denial of service vulnerability in TomWright dasel, published on 21 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Dasel is a command-line tool and library for querying, modifying, and transforming data structures. From 3.0.0 until 3.11.1, parsing/json/json_reader.go decodeValue, decodeObject, and decodeArray, and parsing/xml/reader.go parseElement, recurse once per input nesting level without a depth guard. Deeply nested attacker-controlled JSON or XML supplied through parsing.Format(...).NewReader(...).Read(data), the command-line interface, or the parse selector function can exhaust the Go goroutine stack and raise an unrecoverable fatal error that terminates the entire process. The XML input-size limit does not prevent depth exhaustion, and defer or recover cannot intercept the failure. This issue is fixed in version 3.11.1.

Weakness: CWE-674

Which versions are affected by CVE-2026-59168?

5 open source packages ship an affected version, including github.com/tomwright/dasel/v3, github.com/tomwright/dasel and github.com/tomwright/dasel/v2.

PackageAffectedFixed in
github.com/tomwright/dasel/v3 GoFrom 3.0.03.11.1
github.com/tomwright/dasel/v3 GoFrom 3.0.03.11.1
github.com/tomwright/dasel/v3 GoFrom 3.0.03.11.1
github.com/tomwright/dasel GoAll versionsNone
github.com/tomwright/dasel/v2 GoAll versionsNone

How do I fix CVE-2026-59168?

Upgrade github.com/tomwright/dasel/v3 to 3.11.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-59168 being exploited?

There is no known exploitation of CVE-2026-59168 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-59168, GHSA-cqxr-jxr2-85pq, GO-2026-6549, UBUNTU-CVE-2026-59168.

Is CVE-2026-59168 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free