{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-5917 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-5917 is a high-severity command injection vulnerability in libgit2, published on 11 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-5917 and fix it if it is affected.\n\nWhat it is: CVE-2026-5917 is a high-severity command injection vulnerability in libgit2, published on 11 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-5917 in the wild and no public exploit code.\n\nAffected product: libgit2. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-5917/ (Markdown: https://insights.sbomify.com/CVE-2026-5917/index.md)","id":"CVE-2026-5917","markdown":"https://insights.sbomify.com/CVE-2026-5917/index.md","name":"CVE-2026-5917","record":{"aliases":["BELL-CVE-2026-5917","DEBIAN-CVE-2026-5917","ECHO-25c0-43ef-f653","GHSA-3gwr-xcwq-7892","GHSA-xqj4-2j5v-rr75","JLSEC-2026-1275","OESA-2026-4621","OESA-2026-4622","OESA-2026-4623","UBUNTU-CVE-2026-5917","USN-8809-1","openSUSE-SU-2026:11521-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Git library","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands on SSH servers via malicious repository paths in libgit2 when using the libssh2 backend.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"libgit2 versions before 1.8.7 and 1.9.0 before 1.9.7 built with the libssh2 SSH backend (USE_SSH=libssh2) contain a shell command injection vulnerability that allows remote attackers to execute arbitrary commands on an SSH server by supplying a repository path containing unescaped shell metacharacters such as single quotes, semicolons, or pipes. The gen_proto() function in ssh_libssh2.c inserts the repository path directly into a shell command string without escaping special characters before passing it to libssh2_channel_exec(), enabling an attacker to craft a malicious submodule URL in a .gitmodules file that, when processed during a recursive clone, causes the remote server's shell to interpret injected commands under the victim's SSH user account.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"libgit2 Shell Command Injection via ssh_libssh2 Backend","id":"CVE-2026-5917","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"Information disclosure in Chrome","id":"CVE-2026-5918"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.9.7-1.1"],"introduced":["0"],"last_affected":[],"package":"libgit2","purl":"pkg:rpm/opensuse/libgit2\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11521-1"}],"prev":{"headline":"Memory corruption in Chrome","id":"CVE-2026-5915"},"products":["libgit2"],"published":"2026-08-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-01","vendors":["libgit2"]},"summary":"Remote attackers can execute arbitrary commands on SSH servers via malicious repository paths in libgit2 when using the libssh2 backend.","url":"https://insights.sbomify.com/CVE-2026-5917/"}