CVE-2026-59173 Apache Traffic Server: DoS vulnerability in HTTP/2 via stalled flow-control conditions

High 7.5 Published Updated

Attackers can cause denial of service in Apache Traffic Server by exploiting stalled flow-control conditions in HTTP/2.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-59173?

CVE-2026-59173 is a high-severity denial of service vulnerability in Apache Traffic Server, published on 18 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Uncontrolled Resource Consumption vulnerability in Apache Traffic Server.

This issue affects Apache Traffic Server: from 9.0.0 through 9.1.13, from 10.0.0 through 10.1.2.

Users are recommended to upgrade to version 9.1.14 or 10.1.3, which fixes the issue.

Weakness: CWE-400

Which versions are affected by CVE-2026-59173?

It affects 1 product.

Products include Apache Traffic Server.

How do I fix CVE-2026-59173?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-59173 being exploited?

There is no known exploitation of CVE-2026-59173 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-59173, GHSA-6m23-f848-jcqf, UBUNTU-CVE-2026-59173.

Is CVE-2026-59173 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free