# CVE-2026-59179: OpenHop: Path Traversal in Flow ID File Operations


- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-g72f-jw3w-mgh7

## What is CVE-2026-59179?

CVE-2026-59179 is a high-severity vulnerability in naorsabag openhop, published on 28 Oct 2026. 

### Official description

OpenHop is a tool for creating interactive data-flow diagrams. Prior to 0.3.7, `@openhop/server` passes unauthenticated flow route parameters from `GET /api/flows/:id` and `DELETE /api/flows/:id` in `packages/server/src/routes.ts` to `FlowStore.filePath()` in `packages/server/src/store.ts` without an identifier allow-list. The router applies `decodeURIComponent` to the id, and `path.join()` then normalizes traversal outside the configured flow directory after appending the .yaml extension. An attacker can read accessible YAML files as YAML-parsed JSON or permanently delete accessible .yaml files outside that directory, exposing configuration or secrets and disrupting dependent services. In `packages/server/src/index.ts`, CORS `origin: true` permits any browser origin, enabling a malicious webpage to target a loopback-bound instance. Docker deployments default to `HOST=0.0.0.0` and permit direct unauthenticated network access. This issue is fixed in repository release 0.3.7.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-59179?

2 open source packages ship an affected version, including @openhop/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openhop/server` | npm | All versions | 0.3.6 |
| `@openhop/server` | npm | All versions | 0.3.6 |

## How do I fix CVE-2026-59179?

Upgrade @openhop/server to 0.3.6 or later.

## Is CVE-2026-59179 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59179 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59179 and fix it if it is affected.

What it is: CVE-2026-59179 is a high-severity vulnerability in naorsabag openhop, published on 28 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59179 exists.

Affected packages and fixed versions:
- @openhop/server (npm): affected all versions; fixed in 0.3.6
- @openhop/server (npm): affected all versions; fixed in 0.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59179/ (Markdown: https://insights.sbomify.com/CVE-2026-59179/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59179
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59179
- OSV: https://osv.dev/vulnerability/CVE-2026-59179

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59179/
Summaries are generated and may contain mistakes; the official description above is the record.
