CVE-2026-59180 Apprise forwards configured auth headers across cross-origin HTTP redirects
Apprise library leaks sensitive authentication headers and tokens to malicious servers during HTTP redirects, exposing secrets to attackers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-59180?
CVE-2026-59180 is a low-severity vulnerability in caronc apprise, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. Prior to 1.11.0, Apprise HTTP-based notification plugins and HTTP attachment and config loaders in apprise/attachment/http.py and apprise/config/http.py follow HTTP redirects by default and resend user-configured auth headers and query parameters on the redirected request, allowing a compromised trusted destination or on-path attacker to receive secrets such as Authorization headers, bearer tokens, custom headers, and service keys. This issue is fixed in version 1.11.0.
Which versions are affected by CVE-2026-59180?
3 open source packages ship an affected version, including apprise.
| Package | Affected | Fixed in |
|---|---|---|
apprise PyPI | All versions | 1.11.0 |
apprise PyPI | All versions | 1.11.0 |
apprise PyPI | All versions | 1.11.0 |
Linux distribution packages (1)
python-apprise openSUSE:Leap 16.0 | All versions | 1.9.3-bp160.2.1 |
How do I fix CVE-2026-59180?
Upgrade apprise to 1.11.0 or later.
Is CVE-2026-59180 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59180 exists.
Sources
Also known as DEBIAN-CVE-2026-59180, GHSA-856c-92hv-3vxx, PYSEC-2026-4200, UBUNTU-CVE-2026-59180, openSUSE-SU-2026:21789-1.