{"answers":{"affected":"3 open source packages ship an affected version, including apprise.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59180 exists.","fix":"Upgrade apprise to 1.11.0 or later.","what":"CVE-2026-59180 is a low-severity vulnerability in caronc apprise, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-59180 and fix it if it is affected.\n\nWhat it is: CVE-2026-59180 is a low-severity vulnerability in caronc apprise, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59180 exists.\n\nAffected packages and fixed versions:\n- apprise (PyPI): affected all versions; fixed in 1.11.0\n- apprise (PyPI): affected all versions; fixed in 1.11.0\n- apprise (PyPI): affected all versions; fixed in 1.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-59180/ (Markdown: https://insights.sbomify.com/CVE-2026-59180/index.md)","id":"CVE-2026-59180","markdown":"https://insights.sbomify.com/CVE-2026-59180/index.md","name":"CVE-2026-59180","record":{"aliases":["DEBIAN-CVE-2026-59180","GHSA-856c-92hv-3vxx","PYSEC-2026-4200","UBUNTU-CVE-2026-59180","openSUSE-SU-2026:21789-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python notification library","requires_auth":"none","summary":"Apprise library leaks sensitive authentication headers and tokens to malicious servers during HTTP redirects, exposing secrets to attackers.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. Prior to 1.11.0, Apprise HTTP-based notification plugins and HTTP attachment and config loaders in apprise/attachment/http.py and apprise/config/http.py follow HTTP redirects by default and resend user-configured auth headers and query parameters on the redirected request, allowing a compromised trusted destination or on-path attacker to receive secrets such as Authorization headers, bearer tokens, custom headers, and service keys. This issue is fixed in version 1.11.0.","ecosystems":["PyPI","openSUSE:Leap 16.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Apprise forwards configured auth headers across cross-origin HTTP redirects","id":"CVE-2026-59180","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":4,"n_references":4,"next":{"headline":"OpenImageIO: Stack buffer overflow in OpenImageIO Cineon reader via unchecked numberOfElements","id":"CVE-2026-59181"},"packages":[{"ecosystem":"PyPI","fixed":["1.11.0"],"introduced":["0"],"last_affected":[],"package":"apprise","purl":null,"source":"GHSA-856c-92hv-3vxx"},{"ecosystem":"PyPI","fixed":["1.11.0"],"introduced":["0"],"last_affected":[],"package":"apprise","purl":"pkg:pypi/apprise","source":"GHSA-856c-92hv-3vxx"},{"ecosystem":"PyPI","fixed":["1.11.0"],"introduced":["0"],"last_affected":[],"package":"apprise","purl":"pkg:pypi/apprise","source":"PYSEC-2026-4200"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["1.9.3-bp160.2.1"],"introduced":["0"],"last_affected":[],"package":"python-apprise","purl":"pkg:rpm/opensuse/python-apprise\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21789-1"}],"prev":{"headline":"OpenHop: Path Traversal in Flow ID File Operations","id":"CVE-2026-59179"},"products":["apprise"],"published":"2026-07-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-10","vendors":["caronc"]},"summary":"Apprise library leaks sensitive authentication headers and tokens to malicious servers during HTTP redirects, exposing secrets to attackers.","url":"https://insights.sbomify.com/CVE-2026-59180/"}