# CVE-2026-59183: OpenEXR: Signed Integer Overflow Leading to Out-of-Bounds Memory Access in Deep Tile Decoding

> A signed integer overflow in OpenEXR's deep tile decoding allows attackers to cause a crash via crafted files, affecting any application using the library.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** BELL-CVE-2026-59183, DEBIAN-CVE-2026-59183, ECHO-383b-727d-c60a, GHSA-rqp5-pmwm-wj6x, MINI-424f-8xxm-hf57, UBUNTU-CVE-2026-59183

## What is CVE-2026-59183?

CVE-2026-59183 is a medium-severity vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. In versions 3.1.0 through 3.2.10, 3.3.0 through 3.3.12, and 3.4.0 through 3.4.13, an int32_t multiplication in OpenEXRCore's unpack_sample_table() can overflow while decoding a crafted deep tiled EXR file, producing an invalid pointer that leads to a read from an unmapped memory address and a crash. Because the overflow occurs in the standard decoding path (exr_decoding_run), any application that decodes deep tiled EXR files is affected. This issue is fixed in versions 3.2.11, 3.3.13, and 3.4.14.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-59183?


## How do I fix CVE-2026-59183?

Upgrade to a fixed version.

## Is CVE-2026-59183 being exploited?

There is no known exploitation of CVE-2026-59183 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59183 and fix it if it is affected.

What it is: CVE-2026-59183 is a medium-severity vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-59183 in the wild and no public exploit code.

Affected product: AcademySoftwareFoundation openexr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59183/ (Markdown: https://insights.sbomify.com/CVE-2026-59183/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59183
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59183
- OSV: https://osv.dev/vulnerability/CVE-2026-59183

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59183/
Summaries are generated and may contain mistakes; the official description above is the record.
