# CVE-2026-59187: OpenEXR: exrmetrics deep pixelmode heap buffer overflow

> A heap buffer overflow in OpenEXR allows attackers to execute arbitrary code or cause denial of service via crafted deep scanline EXR files.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** BELL-CVE-2026-59187, DEBIAN-CVE-2026-59187, GHSA-6jj8-cxcr-j8hm, MINI-83fg-28hx-rxg4, ROOT-OS-DEBIAN-11-CVE-2026-59187, ROOT-OS-DEBIAN-12-CVE-2026-59187, ROOT-OS-DEBIAN-13-CVE-2026-59187, UBUNTU-CVE-2026-59187

## What is CVE-2026-59187?

CVE-2026-59187 is a high-severity memory corruption vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. OpenEXR versions 3.3.0 through 3.3.12 and 3.4.0 through 3.4.13 are vulnerable to a heap out-of-bounds write when exrmetrics reads a crafted deep scanline EXR. This occurs with pixel conversion options such as --pixelmode float or --bench because DeepSlice requests FLOAT output while the backing sample buffers are allocated using the input HALF element size. The issue is fixed in versions 3.3.13 and 3.4.14.

Weakness: CWE-787 (Out-of-bounds Write), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-59187?


## How do I fix CVE-2026-59187?

Upgrade to a fixed version.

## Is CVE-2026-59187 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59187 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59187 and fix it if it is affected.

What it is: CVE-2026-59187 is a high-severity memory corruption vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59187 exists.

Affected product: AcademySoftwareFoundation openexr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59187/ (Markdown: https://insights.sbomify.com/CVE-2026-59187/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59187
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59187
- OSV: https://osv.dev/vulnerability/CVE-2026-59187

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59187/
Summaries are generated and may contain mistakes; the official description above is the record.
