# CVE-2026-59190: Grav Admin Plugin — IDOR Privilege Escalation via saveUser()

> An authenticated attacker with user-management permissions can change any user's password, including super admins, due to missing authorization checks in the Grav Admin Plugin.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-p97c-g455-q447

## What is CVE-2026-59190?

CVE-2026-59190 is a high-severity missing authorization vulnerability in getgrav grav, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

grav-plugin-admin is an HTML user interface that provides a way to configure Grav and create and modify pages. In 1.10.52 and earlier, an authenticated attacker with admin.users permission can change the password of any user account, including the super administrator, by sending a direct POST request to /admin/user/{username}?task=save with data[password] because saveUser authorizes the caller's user-management permission but does not verify whether the caller may edit the target user. This issue is expected to be fixed in version 1.10.53.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-59190?


## How do I fix CVE-2026-59190?

No fix has been published for CVE-2026-59190 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-59190 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59190 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59190 and fix it if it is affected.

What it is: CVE-2026-59190 is a high-severity missing authorization vulnerability in getgrav grav, published on 10 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59190 exists.

Affected product: getgrav grav. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59190/ (Markdown: https://insights.sbomify.com/CVE-2026-59190/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59190
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59190
- OSV: https://osv.dev/vulnerability/CVE-2026-59190

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59190/
Summaries are generated and may contain mistakes; the official description above is the record.
