CVE-2026-59193 Grav CMS — Improper Handling of Highly Compressed Data in Installer::unZip()

Medium 6.9 Published Updated

An authenticated admin can crash the system or exhaust disk space by uploading a malicious ZIP archive due to missing extraction limits.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-59193?

CVE-2026-59193 is a medium-severity denial of service vulnerability in Getgrav Grav, published on 10 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Grav is a file-based Web platform. Prior to 2.0.0, an authenticated admin.super user can crash Grav or fill the disk by uploading a specially crafted ZIP archive through the Direct Install tool because Installer::unZip calls ZipArchive::extractTo without limits on uncompressed size, entry count, or directory depth. This issue is fixed in version 2.0.0.

Weakness: CWE-409

Which versions are affected by CVE-2026-59193?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.

PackageAffectedFixed in
getgrav/grav PackagistFrom 1.0.02.0.0
getgrav/grav PackagistFrom 1.0.02.0.0

Products include Getgrav Grav.

How do I fix CVE-2026-59193?

Upgrade getgrav/grav to 2.0.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-59193 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59193 exists.

All Getgrav Grav vulnerabilities

Sources

Also known as GHSA-2vcx-h8p2-9pg9.

Is CVE-2026-59193 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free