# CVE-2026-59193: Grav CMS — Improper Handling of Highly Compressed Data in Installer::unZip()

> An authenticated admin can crash the system or exhaust disk space by uploading a malicious ZIP archive due to missing extraction limits.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-2vcx-h8p2-9pg9

## What is CVE-2026-59193?

CVE-2026-59193 is a medium-severity denial of service vulnerability in Getgrav Grav, published on 10 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Grav is a file-based Web platform. Prior to 2.0.0, an authenticated admin.super user can crash Grav or fill the disk by uploading a specially crafted ZIP archive through the Direct Install tool because Installer::unZip calls ZipArchive::extractTo without limits on uncompressed size, entry count, or directory depth. This issue is fixed in version 2.0.0.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-59193?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | From 1.0.0 | 2.0.0 |
| `getgrav/grav` | Packagist | From 1.0.0 | 2.0.0 |

Products: Getgrav Grav.

## How do I fix CVE-2026-59193?

Upgrade getgrav/grav to 2.0.0 or later.

## Is CVE-2026-59193 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59193 exists.

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2022-2073](https://insights.sbomify.com/CVE-2022-2073/): Code Injection in getgrav/grav (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59193 and fix it if it is affected.

What it is: CVE-2026-59193 is a medium-severity denial of service vulnerability in Getgrav Grav, published on 10 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59193 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected from 1.0.0; fixed in 2.0.0
- getgrav/grav (Packagist): affected from 1.0.0; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59193/ (Markdown: https://insights.sbomify.com/CVE-2026-59193/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59193
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59193
- OSV: https://osv.dev/vulnerability/CVE-2026-59193

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59193/
Summaries are generated and may contain mistakes; the official description above is the record.
