# CVE-2026-59195: pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config

> A malicious repository can exploit path traversal in pnpm's configDependencies to create symlinks outside the intended directory, potentially leading to code execution or data modification.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 7 Jul 2026
- **Also known as:** GHSA-qrv3-253h-g69c, MINI-445g-6xgh-8ggp, ROOT-APP-NPM-GHSA-qrv3-253h-g69c

## What is CVE-2026-59195?

CVE-2026-59195 is a high-severity path traversal vulnerability in pnpm, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

pnpm is a package manager. Prior to 10.34.4 and 11.8.0, pnpm accepts package names from the env lockfile configDependencies section and uses those names directly when creating config dependency symlinks under node_modules/.pnpm-config. A malicious repository can commit a crafted pnpm-lock.yaml whose env-lockfile document contains a traversal-shaped config dependency name. During pnpm install, pnpm installs the config dependency and creates a symlink at a path derived from that name. This vulnerability is fixed in 10.34.4 and 11.8.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-59195?

4 open source packages ship an affected version, including pnpm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pnpm` | npm | All versions | 10.34.4 |
| `pnpm` | npm | All versions | 10.34.4 |
| `pnpm` | npm | From 11.0.0 | 11.8.0 |
| `pnpm` | npm | From 11.0.0 | 11.8.0 |

Products: Pnpm Pnpm.

## How do I fix CVE-2026-59195?

Upgrade pnpm to a fixed version for your release line: 10.34.4 or 11.8.0.

## Is CVE-2026-59195 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59195 exists.

## Other vulnerabilities in pnpm

- [CVE-2026-50016](https://insights.sbomify.com/CVE-2026-50016/): pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement (high 8.8)
- [CVE-2026-55698](https://insights.sbomify.com/CVE-2026-55698/): pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes (high 8.8)
- [CVE-2025-69264](https://insights.sbomify.com/CVE-2025-69264/): pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default" (high 8.8)
- [CVE-2022-26183](https://insights.sbomify.com/CVE-2022-26183/): Untrusted Search Path in PNPM (high 8.8)
- [CVE-2025-69262](https://insights.sbomify.com/CVE-2025-69262/): pnpm vulnerable to Command Injection via environment variable substitution (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59195 and fix it if it is affected.

What it is: CVE-2026-59195 is a high-severity path traversal vulnerability in pnpm, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59195 exists.

Affected packages and fixed versions:
- pnpm (npm): affected all versions; fixed in 10.34.4
- pnpm (npm): affected all versions; fixed in 10.34.4
- pnpm (npm): affected from 11.0.0; fixed in 11.8.0
- pnpm (npm): affected from 11.0.0; fixed in 11.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59195/ (Markdown: https://insights.sbomify.com/CVE-2026-59195/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59195
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59195
- OSV: https://osv.dev/vulnerability/CVE-2026-59195

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59195/
Summaries are generated and may contain mistakes; the official description above is the record.
