# CVE-2026-59199: Pillow: Heap out-of-bounds write `Image.paste()` / `Image.crop()` via signed coordinate overflow

> Attackers can trigger heap out-of-bounds writes in Pillow via crafted image coordinates, potentially leading to code execution or crashes.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-pillow-2026-59199, CLSA-2026-1787039243, DEBIAN-CVE-2026-59199, ECHO-eed4-3da2-904f, GHSA-6r8x-57c9-28j4, MINI-3qrh-gjmh-g9xc, MINI-4xx2-m7v9-m4fg, MINI-57xr-6pv6-fj52, MINI-5cwc-5g42-4qrh, MINI-5vg9-qgvq-3vv4, MINI-76cx-qgh6-m2gr, MINI-f3h4-ph6p-pw2r, MINI-hvm5-xm3c-45q6, MINI-j8f4-p7gx-jph8, MINI-q74j-5qg5-vhcw, MINI-vr32-m25r-wm6p, PYSEC-2026-3451, ROOT-APP-PYPI-CVE-2026-59199, UBUNTU-CVE-2026-59199

## What is CVE-2026-59199?

CVE-2026-59199 is a high-severity memory corruption vulnerability in Python Pillow, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pillow is a Python imaging library. Prior to 12.3.0, Pillow public image coordinate APIs can trigger a native heap out-of-bounds write when given coordinates near the signed 32-bit integer limits in Image.paste(), Image.crop(), or Image.alpha_composite(). This issue is fixed in version 12.3.0.

Weakness: CWE-787 (Out-of-bounds Write), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-59199?

4 open source packages ship an affected version, including pillow and Pillow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | All versions | 12.3.0 |
| `pillow` | PyPI | All versions | 12.3.0 |
| `pillow` | PyPI | All versions | 12.3.0 |
| `Pillow` | PyPI | All versions | 12.3.0 |

Products: Python Pillow.

## How do I fix CVE-2026-59199?

Upgrade pillow to 12.3.0 or later.

## Is CVE-2026-59199 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59199 exists.

## Other vulnerabilities in Python Pillow

- [CVE-2014-3007](https://insights.sbomify.com/CVE-2014-3007/): Pillow command injection (critical 10.0)
- [CVE-2026-96639](https://insights.sbomify.com/CVE-2026-96639/): Pillow multi-frame loaders can reuse stale native image storage after mode transitions (critical 9.8)
- [CVE-2022-30595](https://insights.sbomify.com/CVE-2022-30595/): Buffer over-flow in Pillow (critical 9.8)
- [CVE-2021-25289](https://insights.sbomify.com/CVE-2021-25289/): Out of bounds write in Pillow (critical 9.8)
- [CVE-2016-4009](https://insights.sbomify.com/CVE-2016-4009/): Pillow Integer overflow in ImagingResampleHorizontal (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59199 and fix it if it is affected.

What it is: CVE-2026-59199 is a high-severity memory corruption vulnerability in Python Pillow, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59199 exists.

Affected packages and fixed versions:
- pillow (Bitnami): affected all versions; fixed in 12.3.0
- pillow (PyPI): affected all versions; fixed in 12.3.0
- pillow (PyPI): affected all versions; fixed in 12.3.0
- Pillow (PyPI): affected all versions; fixed in 12.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59199/ (Markdown: https://insights.sbomify.com/CVE-2026-59199/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59199
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59199
- OSV: https://osv.dev/vulnerability/CVE-2026-59199

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59199/
Summaries are generated and may contain mistakes; the official description above is the record.
