# CVE-2026-59200: Pillow: Decompression Bomb DoS via PdfParser.PdfStream.decode()

> Attackers can cause memory exhaustion and denial of service by submitting crafted PDF files to applications using the Pillow library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** BIT-pillow-2026-59200, CLSA-2026-1787043483, DEBIAN-CVE-2026-59200, ECHO-b776-8c4a-970e, GHSA-jjj6-mw9f-p565, MINI-248w-ccvp-jr85, MINI-27jj-4gw2-gg59, MINI-4j6j-328x-whw6, MINI-5g94-hrmv-2rvm, MINI-6fhh-q3fv-m655, MINI-6h67-mmgm-562m, MINI-h92r-6r48-rhp4, MINI-mwhv-9mpc-mvm2, MINI-phvv-84mh-f748, MINI-xfv3-fw2v-h8qc, MINI-xg55-h39q-9532, PYSEC-2026-3495, ROOT-APP-PYPI-CVE-2026-59200, UBUNTU-CVE-2026-59200

## What is CVE-2026-59200?

CVE-2026-59200 is a high-severity denial of service vulnerability in Python Pillow, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pillow is a Python imaging library. From 5.1.0 until 12.3.0, PdfParser.PdfStream.decode() in PIL/PdfParser.py calls zlib.decompress() with bufsize set to the PDF stream Length field without bounding the decompressed output size, allowing a crafted FlateDecode PDF stream to exhaust memory from a small file. This issue is fixed in version 12.3.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-59200?

4 open source packages ship an affected version, including pillow and Pillow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | From 5.1.0 | 12.3.0 |
| `pillow` | PyPI | From 5.1.0 | 12.3.0 |
| `pillow` | PyPI | From 5.1.0 | 12.3.0 |
| `Pillow` | PyPI | From 5.1.0 | 12.3.0 |

Products: Python Pillow.

## How do I fix CVE-2026-59200?

Upgrade pillow to 12.3.0 or later.

## Is CVE-2026-59200 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59200 exists.

## Other vulnerabilities in Python Pillow

- [CVE-2014-3007](https://insights.sbomify.com/CVE-2014-3007/): Pillow command injection (critical 10.0)
- [CVE-2026-96639](https://insights.sbomify.com/CVE-2026-96639/): Pillow multi-frame loaders can reuse stale native image storage after mode transitions (critical 9.8)
- [CVE-2022-30595](https://insights.sbomify.com/CVE-2022-30595/): Buffer over-flow in Pillow (critical 9.8)
- [CVE-2021-25289](https://insights.sbomify.com/CVE-2021-25289/): Out of bounds write in Pillow (critical 9.8)
- [CVE-2016-4009](https://insights.sbomify.com/CVE-2016-4009/): Pillow Integer overflow in ImagingResampleHorizontal (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-59200 and fix it if it is affected.

What it is: CVE-2026-59200 is a high-severity denial of service vulnerability in Python Pillow, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-59200 exists.

Affected packages and fixed versions:
- pillow (Bitnami): affected from 5.1.0; fixed in 12.3.0
- pillow (PyPI): affected from 5.1.0; fixed in 12.3.0
- pillow (PyPI): affected from 5.1.0; fixed in 12.3.0
- Pillow (PyPI): affected from 5.1.0; fixed in 12.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-59200/ (Markdown: https://insights.sbomify.com/CVE-2026-59200/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-59200
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-59200
- OSV: https://osv.dev/vulnerability/CVE-2026-59200

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-59200/
Summaries are generated and may contain mistakes; the official description above is the record.
